It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Mojave: The application “Sourcetree” can’t be opened.

Oddly,  SourceTree wasn't autoupdating wasn't working from my pervious version v2.*.

So I deleted it, downloaded a fresh copy and tried to open it.  But I received the message: "The application “Sourcetree” can’t be opened."  This keeps happening now for every version I download and unzip.

This happens for these versions (from here https://www.sourcetreeapp.com/download-archives):

  • Sourcetree_3.2.1_225.zip
  • Sourcetree_2.7.6a.zip
  • Sourcetree_4.0_229.zip



I'm using macOS Mojave (v10.14.6)

SourceTreeCantBeOpened.png

Help!

Things I've tried:

  • Starting in macOS Safe Mode -- I couldn't start SourceTree
  • Various versions of SourceTree -- I couldn't start SourceTree
  • Toyed around with adding SourceTree in Security & Privacy in both:
    •  Full Disk Access
    • Accessibility

 

Nothing is working so far.

 

1 answer

0 votes
Daniel Eads Atlassian Team Mar 23, 2020

Hi Michael,

Sorry to hear you're having problems getting an updated version of Sourcetree running. Firstly, let's get you the most recent build (232). It sounds like the archive page is still giving you a slightly older build (229), but you can tweak the URL to get the newest version. You can download that version directly from the following link:
https://product-downloads.atlassian.com/software/sourcetree/ga/Sourcetree_4.0_232.zip

One thing that can cause problems opening applications like Sourcetree is MacOS's Gatekeeper. Typically one would see an error message like "Sourcetree can't be opened because it is from an unidentified developer". The fix for this is right-clicking the Sourcetree app and selecting Open from the context menu. An option to continue will be available (vs double-clicking, where it won't be available).

Given your screenshot though, I'm led to believe the error you're seeing is from the executable bit being stripped from the application. It's unclear what causes this to happen, but it's a common enough error across MacOS applications. To test for this, you'll want to open Terminal and run ls -la in the application's MacOS directory to see what bits are set on the binary. The exact path you'll want to test is:

Sourcetree.app/Contents/MacOS

By navigating your terminal to wherever the Sourcetree app is housed, you can do the check quickly by copying and pasting this command:

ls -la Sourcetree.app/Contents/MacOS

Here's an example of what you want to see:

image.pngI've pointed out the executable bit on the Sourcetree binary. If there's no 'x' here, the file doesn't have permission to run and we'll know that this is the cause of Sourcetree not starting. To solve, we'll need to add the execute bit to the binary:

chmod +x Sourcetree.app/Contents/MacOS/Sourcetree

After that, try opening Sourcetree again by right-clicking the app and selecting "Open" (just in case Gatekeeper decides to kick in).

Cheers,
Daniel

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

3,107 views 0 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you