Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Message from GitHub: Basic authentication using a password to the API is deprecated

I'm getting these messages from GitHub that " Basic authentication using a password to the API is deprecated and will soon no longer work" when I access my SourceTree.

They provide this link https://developer.github.com/changes/2020-02-14-deprecating-password-auth/

But I am not sure how to implement that in  SourceTree.

Thanks!

2 answers

1 accepted

1 vote
Answer accepted
Daniel Eads Atlassian Team Jul 31, 2020

Hello Laurel!

You can switch to using a personal access token in place of your Github account password in Sourcetree. Here are the instructions for generating a personal access token in Github:

https://docs.github.com/en/github/authenticating-to-github/creating-a-personal-access-token

Once you've got the token, you can edit the settings for your Github account in Sourcetree and simply overwrite the saved password with the API token instead.

Cheers,
Daniel

I just tried this, and was told to replace my email with my github username. I did that, pasted the PAT in the password field, and was not able to log in.

The old password that had been used with my email continued to work.

Is there more to this process than simply "overwrite the saved password with the API token".

Thanks.

Jeremy,  when I "copied" the key from GitHub and pasted it in the password box; it failed.

I saved the key to a text file, then copied the key from the text file,  pasted it in the password field; that worked.

"Seems" to work at least. I suppose in a month, I'll know for sure.

That is slightly bizarre. Suggests that there are some strange characters when you copy from Github.

I haven't tried again lately. Maybe in the next couple of days ...

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,319 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you