It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Location of Windows Install - 3.3.8

Good evening!

Just a brief rundown of the specs of my computer... Windows 10 64-bit, 32 GB DDR3 RAM, RTX 2070 with an AMD FX-8750.

I wanted to quickly see where the company has determined would be the best place to place the installed folder for Atlassian Sourcetree. I noticed that the installer creates a folder in "C:\Users\[My user]\AppData\Local\Atlassian". In the "Sourcetree" directory within the root folder, sadly, there is no ".exe" located there. Instead I am met with the following files:

  • cache,
  • git_extras,
  • hg_extras,
  • analytics_gas_upload,
  • bookmarks.xml,
  • mcmw.zip,
  • settings.log,
  • sourcetree.log, and
  • [a json file with tokens]

Back in that root folder, I see one more directory:

  • SourceTree.exe_Url_[token info]

Diving inside it only provides another directory with "3.3.8.3848" and a few cache files, profile file and a config file inside. that directory.

 

This seems to be an issue. Can this be elevated?

 

Additionally, it appears that the install file from this website also acts as a launch file (which means, each time I run Sourcetree, I must run the install file to run Sourcetree... It's a little backwards). Can this be confirmed?

 

I regrettably must inform that AppData\Roaming does not contain any inkling of Sourcetree and AppData\LocalLow is also empty, in terms of Sourcetree.

 

Kind Regards,

Jeff

2 answers

Something similar happened to me... there is no Sourcetree app installed in the system, I have to run the installer every time I want to run the app.

I already tried installing/reinstalling, but the installer don't go through the installation process, it just opens the app (with is kite slow)

Is there a Workaround??

SourceTree_installation_issue.png

(I am assuming you're using Windows 10:)

One workaround is to navigate Windows Explorer to "C:\Users\[My user]\AppData\Local\SourceTree", locate the application "SourceTree.exe", right-click it, and select "Pin to Start".

Alternatively, or in addition, you could also select "Pin to taskbar".

Like Andres_Cichero likes this

The installer creates the "C:\Users\[My user]\AppData\Local\Atlassian\SourceTree*" set of subdirectories, which you've already identified.

In addition, it should also create "C:\Users\[My user]\AppData\Local\SourceTree". The actual executable should be stored there.

Different components of the overall application appear to be spread across all of these directories.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,907 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you