Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,074
Community Members
 
Community Events
176
Community Groups

Latest notified update for Embedded GIT to 2.17.1.2 does not install update GIT-LFS

Related to this issue the currently notified update to GIT does not appear to install when updated through the Tools > Options > Git > "Update Embedded" 

It downloads PortableGit-2.17.1.2-32-bit.7z.exe

After extracting and restarting SourceTree the Embedded GIT still shows 2.17.1/LibGit2Sharp 0.24.0 + git-lfs v2.0.2 and notifies that an update to Git-LFS is available.

2 answers

The following approach to "reinstalling" the embedded git thanks to@Nathan Niesen worked for me:

  1. Exit SourceTree
  2. Delete `%localappdata%/Atlassian/Sourcetree/git_local`
  3. Start SourceTree
  4. Chose to install embedded git when SourceTree complained about not finding it.
0 votes
minnsey Atlassian Team Jun 20, 2018

Hi

Can you check the version of Git_LFS.exe in %localappdata%/Atlassian/Sourcetree/git_extras? Is that the 2.0.2 version?

Sourcetree should remove that copy.

Alternatively is it possible you have another copy of Git-LFS installed independently but visible via your PATH?

I'm experiencing the same issue. There's no Git_LFS.exe in %localappdata%/Atlassian/Sourcetree/git_extras and no other copy visible via my PATH (typing git_lfs just gives me a "not recognized" message).

Is there anything else I can check?

I've found the problem already (of course right after posting my question first :-) )

I found 2 versions on my system:

  • %localappdata%/Atlassian/Sourcetree/git_local/mingw32/libexec/git-core contained v2.0.2
  • %localappdata%/Atlassian/Sourcetree/git_local/mingw32/bin contained 2.4.2

 

Disabling the first version (by renaming the file to .NOT) solved the issue.

Thanks @Jeroen Brattinga! I had the same issue with the embedded Git and the "A newer version of git-lfs is available" and found that my `Sourcetree/git_local` also had the duplicate `git-lfs.exe` files with dates that didn't match the other files in the "distributions".

Since there were other files with old dates as well I took the following approach to "reinstalling" the embedded git:

  1. Exit SourceTree
  2. Delete `%localappdata%/Atlassian/Sourcetree/git_local`
  3. Start SourceTree
  4. Chose to install embedded git when SourceTree complained about not finding it.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events