It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

LFS not showing tracked files

Hey

I am having a lot of trouble with source tree LFS on one machine.

We have a gitlab account with lfs enabled by default on the repository.

The problem is that eaven though we have a file that has the LFS rules set up, my computers version of Sourcetree does not read that file at all. If I try to commit an mp3 file to the repository it prompts me that the file should be tracked with lfs. On my friends machine that I setup at the same time everything works as it should.

This is what the .gitatributes file has inside of it.

insideconfig.png

This is what the Sourcetree LFS tracking window shows. It is empty, on the other machine I setup it shows the rules and everything works.

lfs_typestotrack.png

 

I have tried from Options -> Git > Embedded and System, neither does nothing.

triedthese.png

I also tried to make a competely new Repository, initialised LFS, added rules and everything works like it should. Then I can see the LFS file types tracked in the window. As soon as I cloned the existing Repository from the GitLab it again lost the connection to the .gitatributes file and the LFS stopped working.

Is there a way to somehow disable LFS from the Sourcetree once and reinitialize it again? Or somehow to asosiate the .gitatributes file back in to the sourcetree since it seems it does not read it correctly for some reason. As said it works completely normal on the other machine with the same clone of the project.

I have reinstalled sourcetree from scratch using this but no help:

https://community.atlassian.com/t5/Sourcetree-questions/How-do-I-fully-remove-SourceTree-so-that-I-can-do-a-quot-fresh/qaq-p/605355

2 answers

1 accepted

0 votes
Answer accepted

Solved this partially allready. The problem was with the .gitignore file. Deleted the .gitignore file and now everything works like it should. Now to actually solve the problem...

ensure that files you want track are in root. Then only it is tracking.

what is meant by "root" here?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,902 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you