It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

LF would be replaced

My first attempt at Push I get "LF would be replaced by CRLF in PixelEtherMega.ino" . An INO file is source code for the Arduino.

What do I do with it???

4 answers

Hi James,

In Windows a line ending is represented by CRLF, and in Unix systems it's represented by LF. The push is just warning you that your line endings are going to be replaced for that file. It sounds like you're working between both Windows and Linux/Mac on your repository.

This can be disabled if you want by setting autocrlf to false so it doesn't convert the line endings on push. This can be done at the command line / terminal when browsed to your repository location by calling the following:

git config core.autocrlf false

Hope that helps

Kieran - Still a problem.


To be sure I uninstalled GIT completly and reinstalled SourceTree. I still get the same error message. BTW its not a warning its game over error.


I had installed SourceTree with GIT internal this time. So now there is no way to run git config core.autodrlf false its not on my computer anymore. Any other ideas?

It sounds like this should be a configuration option in SourceTree don't you think?

THIS IS VERY DANGEROUS

This answer didn't work for me. The warning was gone but the line endings were still changed SILENTLY. After pushing, I could only delete the remote repository and start over.

I could maybe have prevented this if I had double-checked with

`git config --edit`

But I  didn't know about then, and I can't do it now since I found a way to configure it globally, and this DOES work for me:

`git config --global core.autocrlf true`

Verify:

`git config --global --edit`

OK - I found my way into MINGW32 via your Terminal icon (I didn't know it had been installed) but it does not have a 'config' option in it.

Now I found my way to git config but when I enter:

git config core.autocrlf false

I get back:

"Error encountered dialog" with the message 'Summary' failed with code 128: fatal:bad config value for 'core.autocrlf' in .git/config

I re-installed SourceTree but this time I unchecked the box that said "use default line endings".

This time it worked.

Never saw an option like that during installation of 2.4.8.0, otherwise it would have triggered me immediately.

Confusing things these LFs

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,902 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you