It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Keeps prompting for bitbucket login Edited

Dean O'Connor Jun 29, 2017

I have had this problem for ages, years. It's totally doing my head in.

I have done clean installs, tried to gouge out any remnants of SourceTree profiles (as far as I can tell), but it just keeps happening.

I continuously get a popup (see inserted photo) that prompts me for my Bitbucket credentials. I have entered them countless times and they are correct. I use them to login to the site just fine. I can push commits to my private Bitbucket repos with them. It doesn't matter what I do, this popup just keeps on trucking.

Any ideas before I put a shovel through my screen !!!!

Am on Windows 10 using SourceTree version 2.1.25. This has been happening on all version as far back as I can remember.

SourceTree_2017-06-29_17-44-44.png

2 answers

14 votes
Deleted user Oct 20, 2017 • edited

This prompt is actually from Git Credential Manager. To avoid it, set the following git configuration values:

 

[credential]

    helper = manager # this is required to use GCM

    interactive = false

    modalPrompt = false
Steven Zahm Apr 27, 2018

I've been dealing with this seemingly forever, trying every solution I could find. This here, is the correct answer.

Like # people like this
Kaleb Grace Sep 03, 2018

I'm having the same problem as the original poster.

Ben, where do I set these values? Is it in a file somewhere?

I'm using Embedded Git version 2.17.1/LibGit2Sharp 0.24.0 + git-lfs v2.4.2 + Git LFS Bitbucked Adapter v1.0.6 on Windows Sourcetree Version 2.6.10.0.

Thanks in advance!

Mike Airey Oct 11, 2018

Two of the ways you can set these values:

  • Edit your .gitconfig file directly. On Windows it should be located at %userprofile%\.gitconfig
  • Use git at the command prompt:
    • `git config --global --replace-all credential.interactive false`
    • `git config --global --replace-all credential.modalPrompt false`
Like # people like this
Kaleb Grace Oct 11, 2018

Mike, that did the trick. Thank you, Mike and Ben!

David Freebairn Nov 14, 2018

This is the solution I've always wanted.

Dennis van Gerwen Nov 29, 2018

To edit the config file in the terminal: `git config --global --edit`

Miquel Vila Dec 03, 2018

Finally! Thanks for the help Benjamin!

0 votes
Ana Retamal Ortiz Atlassian Team Jun 30, 2017

Hi Dean! Have you tried wiping your SourceTree preferences following these steps already? If after that, the issue still persist, please provide the following information:

  • Are you connecting to your repositories via SSH or HTTPS?
  • Can you check that your public/private keys have been set up correctly?
  • Does the URL you've used as the remote include the username (so it's https://user@bitbucket.org/owner/repo and not just https://bitbucket.org/owner/repo)
  • Do you have more than one Bitbucket username?
  • Check Tools > Options > Authentication for your default usernames for particular hosts and saved passwords. Is the info there correct? 

Best regards,

Ana

 

Dean O'Connor Jul 01, 2017

Thanks for the reply Ana.

Pretty sure I wiped the prefs previously.

But I yesterday I did remove all projects except for my latest one from the Bookmarks. I haven't noticed the popup today.

So seems to be related to a particular project. Also I might not have always had Pageant running with keys. So it might be combo of your 2nd and 3rd points.

I'll gradually check to see what project might be causing issue.

Thanks again.

Julio Souza Aug 17, 2017

I have the same issue, without having SourceTree installed.

From inspecting the popup process, it's being spawned by a `git` process, which is child of VS Code. I believe that happens because it's trying to check for any updates available on my remote (it's a https repo).

Even if I enter the correct credentials, it still reopens after a while.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

394 views 0 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you