Keeps prompting for bitbucket login Edited

I have had this problem for ages, years. It's totally doing my head in.

I have done clean installs, tried to gouge out any remnants of SourceTree profiles (as far as I can tell), but it just keeps happening.

I continuously get a popup (see inserted photo) that prompts me for my Bitbucket credentials. I have entered them countless times and they are correct. I use them to login to the site just fine. I can push commits to my private Bitbucket repos with them. It doesn't matter what I do, this popup just keeps on trucking.

Any ideas before I put a shovel through my screen !!!!

Am on Windows 10 using SourceTree version 2.1.25. This has been happening on all version as far back as I can remember.

SourceTree_2017-06-29_17-44-44.png

2 answers

This prompt is actually from Git Credential Manager. To avoid it, set the following git configuration values:

 

[credential]

    helper = manager # this is required to use GCM

    interactive = false

    modalPrompt = false

I've been dealing with this seemingly forever, trying every solution I could find. This here, is the correct answer.

I'm having the same problem as the original poster.

Ben, where do I set these values? Is it in a file somewhere?

I'm using Embedded Git version 2.17.1/LibGit2Sharp 0.24.0 + git-lfs v2.4.2 + Git LFS Bitbucked Adapter v1.0.6 on Windows Sourcetree Version 2.6.10.0.

Thanks in advance!

Two of the ways you can set these values:

  • Edit your .gitconfig file directly. On Windows it should be located at %userprofile%\.gitconfig
  • Use git at the command prompt:
    • `git config --global --replace-all credential.interactive false`
    • `git config --global --replace-all credential.modalPrompt false`

Mike, that did the trick. Thank you, Mike and Ben!

0 votes

Hi Dean! Have you tried wiping your SourceTree preferences following these steps already? If after that, the issue still persist, please provide the following information:

  • Are you connecting to your repositories via SSH or HTTPS?
  • Can you check that your public/private keys have been set up correctly?
  • Does the URL you've used as the remote include the username (so it's https://user@bitbucket.org/owner/repo and not just https://bitbucket.org/owner/repo)
  • Do you have more than one Bitbucket username?
  • Check Tools > Options > Authentication for your default usernames for particular hosts and saved passwords. Is the info there correct? 

Best regards,

Ana

 

Thanks for the reply Ana.

Pretty sure I wiped the prefs previously.

But I yesterday I did remove all projects except for my latest one from the Bookmarks. I haven't noticed the popup today.

So seems to be related to a particular project. Also I might not have always had Pageant running with keys. So it might be combo of your 2nd and 3rd points.

I'll gradually check to see what project might be causing issue.

Thanks again.

I have the same issue, without having SourceTree installed.

From inspecting the popup process, it's being spawned by a `git` process, which is child of VS Code. I believe that happens because it's trying to check for any updates available on my remote (it's a https repo).

Even if I enter the correct credentials, it still reopens after a while.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

990 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you