Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Issue with sourcetree with latest Windows 10 upgrade

First of all I am extremely happy with SourceTree and use it on a daily basis.

I updated windows 10 a couple of days ago and this rendered the GUI for sourcetree invisible. I could see that it was loaded and that pagent was active, but the region where the GUI should be I saw only a transparent box. AS you can imagine this is far from ideal...

When I reverted back to the previous version of Windows everything was fine. Are you aware of this issue? If so do you have any suggestions other than avoiding future updates?

Jeff McNear

jeff@plasterdog.com

847/849-7060

4 answers

0 votes
Ana Retamal Atlassian Team May 08, 2018

Hi Jeff, I'm glad that you're such a happy Sourcetree user! :D

Regarding your issue with Sourcetree being invisible, this is most likely an issue with either your video-card drivers, your DirectX version, or something related to that.

Can you try the following? Keep in mind that it's going to disable hardware acceleration for all WPF apps but may solve the problem:

Set the following registry key to a DWORD of 1, and then restart your computer:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics\DisableHWAcceleration

 Let us know if it worked for you!

Best regards,

Ana

You guys may want to look into this:

https://docs.microsoft.com/en-us/dotnet/api/system.windows.media.renderoptions.processrendermode?redirectedfrom=MSDN&view=netframework-4.8#System_Windows_Media_RenderOptions_ProcessRenderMode

It's explained there how to resolve this issue for WPF applications - Please add a setting users can use to disable it for just SourceTree?

Thank you for your response, if I understand correctly you are saying that making this change will prevent further video-card driver updates, is that correct?

Also can you further define how I would make the settings change you suggest, is this something that I need to access via the command line?
(remember I rely on your GUI for git)

Thanks in advance,

I'm having the same problem, I think. Today I tried to open SourceTree and the applications loads but nothing appears. The only thing different is I updated my windows OS (https://support.microsoft.com/en-us/help/4103721/windows-10-update-kb4103721). 

 

I haven't been able to fix it. 

I also updated windows ... my current work around is to revert back to the last restore point of windows

I "uninstalled" the update I mentioned above and that didn't work. I will try to go back to an older restore point and just work from there until this gets fixed, I guess. 

I cant even get the restore point working for my computer because of security issues. :/ Looks like I'm stuck not being able to use SourceTree...unfortunate because I like it a lot. 

At least for me this has resolved and procrastination is its' own reward. Windows forced an update and I no longer have the issue originally described above. I can only think that this was a windows error which has been fixed and (astonishingly) microsoft isn't admitting any mistakes,

Oh yes, I forgot to update you: It "suddenly" started working for me the next day. :) I agree with you...that is probably what happened.

Happy to be able to use SourceTree again! 

I'm pleased to hear that you are alright!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,332 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you