Issue with cursor lag on high refresh monitor

alex-bane February 26, 2019

Hey, I have the latest version of sourcetree and on my main monitor (120hz), the cursor lags noticeably, while it doesn't do that on my second monitor (75hz). I tried running it as an administrator or with compatibility settings (for win 7/8) but no luck. CPU usage is not an issue, and the repository I have is a brand new one (even with the repo closed I still have cursor lag). 

Any idea what could fix this? Is there any hardware acceleration available or something? 

2 answers

1 vote
alex-bane February 27, 2019

Think I found the solution. Go to nvidia control panel, manage 3D Settings, add the program to the list of programs (In Program Settings), then select "Fixed refresh" for Monitor Technology. 

alex-bane February 28, 2019

Sadly this actually bring in another issue, that shadowplay latches onto the program now and messes up the window with frame rate display limiting my ability to record the main screen. 

I'll have to switch to kraken sadly, that one is more stable 

0 votes
minnsey
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 27, 2019

We have seen odd issues to do with graphics cards drivers that have been fixed after updating those drivers, could that be applicable here?

alex-bane February 27, 2019

I have a fairly recent Nvidia driver. Could be. 

Last night I also tried adding sourceTreee in the list of programs that have their 3d settings managed in the Nvidia Control pannel. It fixed the issue, but it was only temporary. I will play around with that today again to see if I can get it stable 

alex-bane February 27, 2019

found the solution, see answer 

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events