Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Is this a drawing bug in the Sourcetree UI?

This just started happening after the new year. Certain text and some other objects in Sourcetree for Windows randomly appears in a huge zoomed-in size when refreshed by mousing over or highlighting. Repository tabs, menu toolbar, and the action buttons also have issues appearing differently or not at all. With more refreshing it can sometimes go back to normal. Scrolling with the mouse wheel in dialogs that can scroll seems to always redraw it correctly as well as dragging it to another monitor. Interestingly, when a row or selection of text does get messed up it appears to always be in the exact same manner.

I wasn't on the latest version of Sourcetree so I tried updating and also restarting my PC but the issues are still there. I'm using Build 19042 of Windows 10 and 3.4.7 of Sourcetree. I tried changing some settings. The theme and "use fixed-width font for commit" were the only ones that seemed like they would make a visual difference.

There are several parts that never seem to have any issues, like the code Diff and the commit graph area as well as the branch/tag/etc names under their expanded tree views.

Does anyone have any ideas on what is going on? Any advice would be much appreciated.

-Brian

Screenshot 2022-01-05 115946.pngScreenshot 2022-01-05 115947.pngScreenshot 2022-01-05 120201.png

 

Screenshot 2022-01-05 113233.png

 

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

7,131 views 5 13
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you