It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Is GitFlow integration broken for SourceTree 3.1.2?

I have been using GitFlow integration with SourceTree on Windows 10 x64 without problems, until I recently upgraded to 3.1.2.

Now, when I switch to the master branch, and go to the GitFlow actions menu, there's no Create Hotfix option, just Finish Feature and Other Actions. If I go to Other Actions, I can see Create Hotfix, but when I click that and give a hotfix name e.g. ABC-123-fix-this-bug, it creates the branch without the hotfix prefix i.e. master -> ABC-123-fix-this-bug, instead of master -> hotfix/ABC-123-fix-this-bug.

If I then create the hotfix manually by branching from master, and I want to finish the hotfix, the Finish Hotfix option is again missing from the main GitFlow menu with only Finish Feature being present. If I go to Other Actions, then Finish Hotfix, it brings up the dialog, but after a second or two, clears the hotfix/ABC-123-fix-this-bug entry from the dropdown and gives me an empty dropdown box, so I can no longer finish the hotfix.

I haven't tried creating/finishing releases, but I am not full of confidence...

5 answers

Updating Git resolved the error for me...

Capture.PNG

I am facing the same issue with a clean install of Sourcetree 3.2.5 and git 2.2.0.


After cloning a repo, and initialising with default settings for git-flowCapture.PNG

Full output: 

git flow init -d
Using default branch names.

Which branch should be used for bringing forth production releases?

- master
Branch name for production releases: [master]
Branch name for "next release" development: [develop]

How to name your supporting branch prefixes?

Bugfix branches? [bugfix/]
Hooks and filters directory? [C:/Repos/tradeitem-sapi/.git/hooks]
Completed successfully.

It seems that prefixes are not properly set. Next flow action becomes:

Capture.PNG

---- SOLUTION:

repository->repository settings -> "edit config file..."

Add:

[gitflow "prefix"]
bugfix = bugfix/
feature = feature/
hotfix = hotfix/
release = release/

 

Fixes the issue. Capture.PNG

 

Would love to find out how to solve the issue so Gitflow adds the prefixes correctly.

Thanks for this, I had the same issue and this fixed it

0 votes
minnsey Atlassian Team Mar 22, 2019

Hi

Thanks for raising this we weren't aware of any issues but we will investigate. Can you let us know what version of Git you are running?

minnsey Atlassian Team Mar 22, 2019

FWIW When clicking the Git-Flow button Sourcetree should be comparing the name of the current branch against the various prefixes, hotfix/, feature/ etc and then using that match or lack of it to decide what options to show.

Can I ask what version of Git you are running, so far we've only been able to reproduce this with related issue with Git 2.21.0.

https://community.atlassian.com/t5/Sourcetree-questions/Missing-Start-Feature-right-after-Gitflow-init/qaq-p/1038313#U1039511

Can you confirm that it works with Git < 2.21.0 ?

m currently using the System Git version 2.21.0/LibGit2Sharp 0.25.4 + git-lfs v2.7.1. If I switch to the embedded version, which is 2.20.1/LibGit2Sharp 0.25.4 + git-lfs v2.6.1, then the Finish Hotfix menu action appears. I haven't tried it yet, because I haven't finished the hotfix yet, but just the fact that it is there now when it wasn't before gives me a bit of confidence.

minnsey Atlassian Team Mar 25, 2019

Thanks for confirming, we are continue to investigate what is different with 2.21.0

minnsey Atlassian Team Mar 25, 2019

It looks like an update to fix this should be on its way via Git for Windows https://github.com/git-for-windows/git/issues/2139

Hi Minnsey,

I have the same problem. I made some screenshots.

This is the message that i receive when i try to use any gitflow operation clicking from SourceTree gitflow button.

SourceTree Warning.png 

But i have installed the git version 2.22 on my pc.

 

Git Version.png

Please help me or help us to find a fix or a workaround. 
Thanks in advance

Patrizio

minnsey Atlassian Team Aug 12, 2019

Hi Patrizio

Can you confirm that Sourcetree is using that Git install? Check the version in the Tools/Options/Git tab.

This just started happening for me as well, but the prefixes are in the config file.

Sorry, I was in the wrong repo. This did fix it. Mine looked like this:

feature =
bugfix =
release =
hotfix =
support =
versiontag =

I have the same problem with Sourcetree for windows (3.3.4).

When initializing git flow in repo through Sourcetree interface with default values, no prefixes are added in the git config file, and then I'm experiencing the same problem as others.

When doing git flow init -d through command prompt (through system git), git-flow is initialized, prefixes are configured properly. 

Sourcetree is using system git (version 2.24, just updated) with git-flow version 1.12.3 (AVH Edition), but the initialization obviously still doesn't work from Sourcetree.

Do you have any plans to fix this? 

Also, completely unrelated note: flow, where you are forcing users to log in before using Sourcetree, is absolutely bad and you should fire whoever recommended that just because you wanted to increase the number of registered users. 


Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,902 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you