Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Installing SourceTree 1.8 in an Offline Environment

Bryan Barnhart February 23, 2016

Hello,

 

I'm currently using sourceTree in an offline environment, but the initial splashscreen requires connecting to the Atlassian webserver to start. Is there a way to bypass this and use the current license file I already have for sourceTree?

20 answers

1 accepted

13 votes
Answer accepted
Stig_Synnes
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 23, 2016

It is possible to install SourceTree 1.8.2 on an offline Windows environment. This can be done by first installing it on an online computer and registering there. Next, copy the folder %USERPROFILE%\AppData\Local\Atlassian (or a subset, perhaps only \SourceTree\sourcetree.license) over to the offline computer. Then SourceTree runs. 

I have not yet verified that this solution is in line with the license agreement. Any idea? 

Karl Oelschlaeger February 24, 2016

Confirmed this on Windows 7 x64 with 1.8.2.2. The sourcetree.license file is no longer used. It appears to be a combination of the following:

%USERPROFILE%\AppData\Local\Atlassian\SourceTree\accounts.json

%USERPROFILE%\AppData\Local\Atlassian\SourceTree.exe_Url_<hash>\1.8.2.2\Startup.Profile

%USERPROFILE%\AppData\Local\Atlassian\SourceTree.exe_Url_<hash>\1.8.2.2\user.config

Bryan Barnhart February 24, 2016

Yup! This worked for me on Windows 7 x64 as well. Thank you.

Prashant Pathak February 24, 2016

Can we get a proper solution that isn't a workaround? Shouldn't this be logged as a bug somewhere or do the developers look at the questions here?

Like Florian Grand likes this
C Monster March 15, 2016

I copied over the accounts.json file and was able to start the program, then just opened the working directory.

robertlagrant March 24, 2016

This is incredibly unslick. Thanks, Atlassian!

bpaul1
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 14, 2016

If you have to copy the user.profile into the new installation, won't that contain the user details for whichever user registered the product? Is there a way of licencing it for corporate use, then stripping out the user details for a generic build?

Lou
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 3, 2016

Terrible!  This is not an answer, this is a hack.

3 votes
burgerS September 28, 2016

Same here!
Our customer compliances disallows direct internet connections from our workplaces for security reasons!

This "feature" implies a very bad image to the security concept & considerations of Atlassian :-(

3 votes
Prashant Pathak February 28, 2016

Seems that this is a bug so anyone affected should report it as such.

I couldn't find out how to do this the first time round because it was hidden away on the support site. Here's a direct link to report a SourceTree bug: https://support.atlassian.com/servicedesk/customer/portal/1/create/4

Bryan Barnhart February 29, 2016

Awesome. Hope this fix will make it in quickly.

2 votes
chhabs
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 1, 2017

Hey Everyone - Unfortunately, we don't support offline installations. That said, it is a one-time registration and once you authenticate with a valid Atlassian account, you'll be able to use SourceTree entirely offline. In February, we updated our Terms and Conditions to align with Atlassian's Customer Agreement. The registration requires everyone to acknowledge those new terms and also ensure that SourceTree is distributed in accordance with Export Control laws. Sorry for the inconvenience this change has caused. 

Thank you for your support. 

Rahul

SourceTree Product Manager 

 

 

Vimal Gopal
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 9, 2017

Looks like I will have to migrate back to Github. :-(

Like Mostafa Dindar likes this
David Karnick
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 25, 2017

"Unfortunately, we don't support offline installations." But ... why?

Rick van Twillert (TMC) August 23, 2017

Hi Rahul, this is very inconvenient and unacceptable for enterprises. How do you deploy/maintain sourcetree at atlassian? How do you force your users to use the latest sourcetree given the the amount of security advisories you send out for git and sourcetree?

I really think Atlassian should think about a way to enable unattended/silent installation for sourcetree, make it managable through sccm. You could validate, while silently installing, if there is a BitBucket Server instance on the local network or something. You are promoting this product and we are paying good money for BitBucket Server each year. We have over 1100 sourcetree installations in our company and they range from version 1.1 to 2.1.10. It's undoable and a great security risk. Please think about this and about your enterprise customers!

mdez August 28, 2017

This arbitrary decision precludes the use of this product behind any security hardened network. It's very inconsistent way to manage products in the same suite of tools by the same company.

James Brown September 26, 2017

Being that there one needs to install online, there is currently a serious issue. If I uninstall Source Tree using Windows to uninstall, then run the install package, when I get to the login screen it is a blank screen, thus preventing me to install Source Tree.

Michael Callahan
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 27, 2017

Same problem at my company, which recently adopted Atlassian in a big way.  Enterprise customers are all going to have the same issue.  The need for this is perplexing, and the explanation above doesn't scan.  No one else does this.

Very recently there was an offline-installable version released, which I found by hunting through the boards.  It worked great in our hardened server network, and it seemed that Atlassian was going to fix this once and for all.  Now we're back to this same unnecessary problem with 2.3.5.  Not impressed with the support so far.

Timothy Fish
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 17, 2019

So, basically the "answer" is to tell companies who are trying to protect their software is that they doing something wrong. As for the comment about "Export Control Laws", if companies are hiding their own software away from the outside world then it would be awfully hard to export a tool they are using for their software.

Rick van Twillert (TMC) April 17, 2019

You are aware that Atlassian made some steps since this discussion and Sourcetree for Enterprises is available from the sourctreeapp.com website:

https://www.sourcetreeapp.com/enterprise

Though it still flaws at some points, it makes lives a lot easier for enterprises trying to manage their installed base ;)

Craig January 20, 2020

@Rick van Twillert (TMC) But that still doesn't allow you to install without having to register each time!

We are wanting to use it in an environment with mandatory profiles, so every time it gets launched you're having to essentially go through the registration process each time...It's nuts.

burgerS January 20, 2020

I have to agree with @Craig.
The "Enterprise Solution" forces every user to go through the final setup after installation (Registration/Login).
This is an unacceptable solution in mid-size or larger companies because it unnecessarily increases the support effort for the software (Keyword: Unattended Deployment).

@Craig:
I could share the information, how we handle this in our company at the moment (from a "technial view"), if you are interested?

Like Craig likes this
Craig January 20, 2020

@burgerS - I would be interested to here your thoughts for sure

Rob Grant March 20, 2020

@Rahul Chhabria it's not exactly "unfortunate" when it's functionality that SourceTree deliberately removed.

1 vote
Daniel July 27, 2017

For us this effectively prevents further usage of SourceTree in our company as we automate software distribution for wide-spread products, including automatic (controlled) rollout of updates etc. ...

Very non-customer-oriented move by Atlassian :-(

1 vote
Lou
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 3, 2016

I guess Atlassian doesn't want us using their software.  If older versions supported it, and now newer ones don't, that's sending a pretty clear message to customers.  

I'll think twice next time a conversation about purchasing newer tools comes up.

1 vote
Karl Oelschlaeger February 23, 2016

Same here. An option to import a license file like 1.5, 1.6, 1.7 would be nice.

0 votes
Zack Kendall
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 12, 2019

Same problem. Trying to install on a Windows Server with no internet...

0 votes
SecondIT Logiwatch
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
August 2, 2018

Got same problem. Offline, without access to HTTPs, only SSH to Bitbucket.

We may switch to GitExtensions.

0 votes
Dwayne King
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 14, 2017

I'll add my voice here too.  Completely unable to use sourcetree now because of our development environment being complete "air-gapped" from the internet.

What's next?  JIRA needing a connection to upgrade?

0 votes
Thorsten Führing
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 22, 2016

Guess I'm luck we still have 1.6 running behind our firewall sadsad.

0 votes
Raghu
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 23, 2016

Same issue.. not able to install without internet

0 votes
Greg McKenzie May 23, 2016

any progress on getting sourcetree in offline environment?

0 votes
cardinal4 May 16, 2016

SourceTree Version 1.9.1 (Early Release) suffers from the same issue - it wouldn't let you go on without logging into Atlassian.

0 votes
Chris Bourque
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 10, 2016

I am trying to install in an ONLINE environment but each time I attempt to login to My Atlassian the result is a 403 forbidden.  How frustrating!!!

 

Everything was working fine until I upgraded.

0 votes
Alec McTavish February 24, 2016

Thanks for the info, all. FYI - I've posted a new question focused on licensing / pre-configured installs at https://answers.atlassian.com/questions/37045042

0 votes
Karl Oelschlaeger February 24, 2016

I did a diff on the contents of %USERPROFILE%\AppData\Local\Atlassian from a clean installation before and after registering online.

%USERPROFILE%\AppData\Local\Atlassian\SourceTree\accounts.json is created.

%USERPROFILE%\AppData\Local\Atlassian\SourceTree.exe_Url_<hash>\1.8.2.2\Startup.Profile is modified.

%USERPROFILE%\AppData\Local\Atlassian\SourceTree.exe_Url_<hash>\1.8.2.2\user.config is modified.

After some cursory analysis, my guess is the registration is getting baked into one of the binary objects stored in user.config

0 votes
Prashant Pathak February 23, 2016

And I have the same problem (on Windows).

0 votes
iiieii
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 23, 2016

Same problem. Just updated my SourceTree in isolated network and couldn't start it...

0 votes
Alec McTavish February 23, 2016

Likewise. Updated to 1.8.2 today hoping the licensing system might have been simplified (educational environment, trying to get SourceTree to work well in my classroom, where computers re-image when rebooted). Appears that the opposite has happened, and our offline license file no longer works – getting splash screen / requirement to connect after updating from 1.6.

All help topics on corporate licensing I could find (e.g. https://confluence.atlassian.com/sourcetreekb/sourcetree-license-for-corporate-usage-388404078.html, https://confluence.atlassian.com/sourcetreekb/sourcetree-silent-installation-windows-732267345.html have the following message:

PAGE NO LONGER VALID WITH THE RELEASE OF SOURCETREE FOR MAC OSX 2.2 AND SOURCETREE FOR WINDOWS 1.8

Is there no longer a corporate license key option?

 

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events