Installer login error and can't finish Windows install for SourceTree

I'm trying to install SourceTree on Window7Ultimate, I get as far as entering my Atlassian account details in the box that pops up after pressing the "Use an existing account" part of the installer. When submitting that I get an error saying "We've encountered a problem. Please try again in a few minutes".

Have tried it now and at various times over 24 hours and I still get the same result. However, at one point yesterday I did get it to connect and the installer then continued, but part way through it threw up an error saying:

"Download of Git Credential Manager for Windows - Fork from https://downloads.atlassian.com/software/sourcetree/windows/gcmw-v1.12.0.zip failed because: System.Net.WebException: The remote server returned an error: (404) Not Found"

After that SourceTree then appeared to load its GUI okay, but as I don't fully know how or what is right yet in terms of what ST does, I decided to uninstall it and try again (I found out to do a reinstal), but now I just get back to the same 404 message as above over and over again.

I've tried the other button "Go to My Atlassian" but that just takes me to my license page and doesn't do anything else. At one point I read something about problems with various browsers and maybe requiring IE. I normally use Chrome but I tried altering the defauly browser to first Opera and then IE. It was on trying IE with the "Go to My Atlassian" and then trying "Use an existing account" that I got as far as the one time the login did work, but I think this was just a lucky chance rather than anything browser specific issue which I can't repeat. 

Any ideas anyone? Is there a problem with the installer or Atlassian server? I can otherwise log into the Atlassian site just fine via any browser, it's just the installer login that's the issue (and the 404 part of the process) - NB, I am admin and have run installer as admin.

2 answers

Have you tried a recent older version?

Nice idea - really! Almost as good as "Have you tried turning it off and then on again?".

So, I've just tried the last two previous releases (2.1.2.5 and 2.0.20.1) and they do the same -  "We've encountered a problem. Please try again in a few minutes" (and yes, I have also tried turning it off and on again!)

NB - worth noting is that the download archives for 2.1.2.5 incorrectly point to the previous version - changing the call in the URL bar enabled me to get the right download.

All my other system's (complex) software working fine as as expected, it's just this installer.

I am facing one of the same problems. No reason to get snotty. I asked because I was just about to try this very thing.

I deleted the files in appdata/local/ (because uninstalling doesn't remove them) and then installed 2.0.20.1. I didn't get the error about the Git Credential Manager.

Starting to think this isn't a very well developed tool. Lots of people having problems with repeated Bitbucket password requests...

Hi Tim - Sorry, I wasn't being snotty, honest - just trying to be humorous (which is why I added "really". I really meant it - it was a good idea. Maybe I should've added a :)

:)

I'm feeling the same about the whole Atlassian stuff. I started wanting to get Git, found out SourceTree was good for my needs, realised I needed to join BitBucket and on the way I joined HipChat - got myself in a complete mess with the joining login process which eventually I realised had to all the through the one Atlassian ID thing (they said in a help file from a couple of years ago that their new ID thing would simplify things for new members- Ha! - I haven't come across such a confused and convoluted set of installation and joining processes for years and I've spent hours on it all over a couple of days and got nowhere at all.

On top of that I see having one login/password across all the software as a potential security risk - if one thing gets compromised, the whole lot does. 

I just tried the installer on an iMac, which did get through the login but for some reason I can't get it past the SSH config stage. I;ve connected my BitBucket and created a key but the button to continue remains greyed out and the help files/tutorials don't seem to cover what to do during initial install - copied the key to BitBucket and approved ST but then what?

It's driving me nuts.

For Windows I did the same thing as you by deleting/moving the appdata/local folder after spending a while trying to figure out why the normal Win uninstall process did nothing but removing the icon and nothing else - very strange behaviour - Crazy - not enjoying Atlassian at all and I've still yet to even try Git/BitBucket etc., which will be another minefield in itself to get to grips with.

I did read in some forum comment from a while ago that IE needs to be the default browser, which in my opinion is asking for trouble in itself - I might try that again (at least for the installation process).

Hope you have more luck than me.

Oh, okay. I'm sorry I misunderstood. :-)

I started using git with the command line and just the Git program. That all seemed to work as expected. If you are familiar with *Nix terminal, then it should seem very logical.  I followed some interactive Git tutorial and was able to actually finish the little project I needed to do.

The Bitbucket website also seems to work in a consistent manner.

I haven't been able to get SSH to work on the Digital Ocean droplet I am working with now. It just doesn't seem to like my key.

I am not sure there is really a compelling use case for the scale of projects I work on (solo dev, mom and pop business).

I guess I will try one of the other Git GUI programs and see if it makes more sense.

Good luck to you, too.  :-)

I'm just a small-scale business/designer, trying to tweak the odd bits of code, mess around with various config files, all to get things working the way I want/need.

I need to get to grips with Git/Repos, etc., because not only do I get completely lost as to what's going on at anyone's Git repo when I find myself at one for many reasons it seems these days, but I also need to get more serious about my web design/hosting services, mostly with WordPress at the moment.

I hate command line things, been there and vaguely done that on various platforms since way back. There's too much to remember and I can do it after hours of hunting forums and finding the right (verifiable) combinations of commands and options to run, but ultimately I believe in the GUI as the way forward otherwise I can't take it all in and I get lost/forget.

I'd be interested to hear of any other GUI Git combinations you know of that are a good way to go. Yesterday I read a few things about the differences between Git and Mercurial (I think it was one of the alternatives to choose when setting up BitBucket). From what I gleaned, for my needs and GUI point-and-click way of being, is that I should go for Mercurial? It's mostly just for personal use and will hopefully help me keep track of things,

It's taken me a while to understand the whole *Nix world, SSH'ing, Keys, Putty and in general CMS's (Magento, WordPress & Joomla!), and as for the weird world of LAMP stacks, the GUI's that WHM & cPanel try to be, well that's another moan.

Maybe I should be looking at this whole DigitalOcean Droplet thing (is it good from the UK, reliable, cheap, easy?) Tried and used AWS S3 for a while, read about their instances and all sorts, etc., but it's all way beyond mere mortals to use and keep ahead of.

Art

I faced the same problem yesterday. Have you managed to install SoureTree?

I tried many times over many days in various ways and had no luck beyond the one time early on when it did get past the register window but it then failed to download all its software components.

I've now mentally given up for the time being!

Let me know if you find a solution. 

Someone from Atlassian team is trying to help me here

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

832 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you