Installation of SourceTree cannot be completed because of problem while Log in with Atlassian Id Edited

I've tried to install SourceTree (2.1.2.5) on Windows 7 several times over the last two days. It always gives the message "We've encountered a problem. Please try again in a few minutes." in step "Atlassian account" (see attached screenshot). I try to login with my Atlassian Id. Id and password are correct (I've used the same to login to ask this question).

What is the problem that has been encountered? When will this problem be fixed?

Capture.PNG

23 answers

To every one, try "Reset your Internet Explorer Settings" in IE internet option advanced tab, also check "Delete personal settings"

It works! Thank you very much!

Worked for me too!
Thanks :)

Worked for me!! Cheers!

Worked for me as well, thank you very much. c:

5 votes
Mike Corsaro Atlassian Team Aug 24, 2017

Hello everyone, could you try the following workaround:

  1. Open IE, click on the gear
  2. Select "Internet Options"
  3. Select the "Security" tab
  4. Select "Custom Level" for Internet
  5. Find "Access data sources across domains" and select "Enable" (make note of what the setting currently is)
  6. Try logging into Sourcetree again
  7. After loggin in, follow steps 1-5, but reset the setting back to the previous option.

Changing the security level didn´t solve the problem.
I´m very disappointed that the atlassian team couldn´t fix the problem within 17 days.

As Noam Lugasi said, reseting the IE is the solution.

Lowering the IE security settings worked for me! Thanks.

Worked for me as well.
New installation of Windows 10 Enterprise 64-bit.

Changing IE security worked for me as well!

Hello community,

this also was the solution for me. I had those issues using a Windows 10 x64 with IE version 11 and SourceTree version 2.1.10.0.

Edit:

On the other hand, a colleague of mine faced the same issue and we were however not able to solve it with any of these steps mentioned above. Quite strange! And also very disappointing from Atlassian! It's nearly a month gone since this issue has been posted the first time and nothing has changed! My colleague has a computer with the same OS and IE and also has tried the new installer version 2.1.11.0, but that couldn't help either!

Unfortunately at the moment we are restricted by the default .NET/WPF WebView for the registration process and this relies on IE and its settings.

We are investigating alternatives at the moment,

This worked for me!

Having a "related" issue.
During the install process, I get to "Altassian account", select "Existing account" and nothing is displayed. 

Windows 10 Enterprise 64bit
Installing: SourceTreeSetup-2.3.1.0.exe
sourcetree.PNG

Hi @John Bagagem! The one you're reporting is a different issue. That one has been reported in our bug tracker at SRCTREEWIN-7244. This workaround seems to be working for most of the users:

From a working install collect the accounts.json and passwd files.

Delete the Atlassian folder from the AppData/Local directory for your user. Run the installer for 2.3.1, close it when you get the blank login window. Place the account.json and passwd files into the Atlassian/SourceTree folder. Rerun the installer. It should detect the account and password from those files and bypass the request for a login.

Note that in order to be in compliance with the Atlassian EULA you must ensure the email address used in the file is valid, yours and associated with a valid Atlassian account.

In the meantime, our developers continue to work with the id.atlassian.com team to implement a proper fix.

Let us know if it worked for you!  

Cheers,

Ana

Working like a charm !

Thank you :)

Works like a charm !

Thanks mate :)

Cheers.

Glad to hear that @Frédéric MICHELETTI!

Have a good day :)

Ana

This didn't resolve the issue for me. I did some debugging and even though the error message is provided in the response AJAX message, it's not displayed in the UI (why?)

The error is "Origin header required." Not currently sure hwo to force IE to send this, starting to wish the install size increased by 50MB to embed CEF or Chromium.

I also have the same problem.

Win7 x64 with SP1.

Using a domain network as well.

Login works in all web browsers but not with the application.

IE 11.0.9600.18314

I have the same issue since yesterday on Windows 10. I am able to log in via website on Opera but I can't do it on desktop sourcetree app. I am using latest version: SourceTreeSetup-2.1.10.0.exe 

I have also experienced this issue.

I am on Windows 7, can log in on chrome but the application delivers the same error message as shown above.

Also tried earlier version of source tree. Urgent issue as I need it for work.  

Hi All.
Same Here,but it's working.

I tried....
Internet Options (or Internet Properties) -> [Advanced] tab
`Security
` Do not save encrypted pages to disk (uncheck the checkbox)


OS : Windows 7 pro SP1(64bit)
IE : 11 (11.0.9600.18792)
SourceTree : Ver. 1.9.6.1, 2.3.1.0
etc : domain network, under proxy, with anti-virus software

I hope this helps.

helped for me, at last! - after several hours of trials and googling.

I found several hints what to try and some of them were reported to work, but none of the worked for me :-(

It appears that the authentication procedure in the installer is completely broken since it is based on some obscure IE feature that works under certain conditions only :-(

Thanks a lot!

0 vote

Hi Christian, just to check can you login directly to Atlassian account https://id.atlassian.com using IE? SourceTree relies on the WPF web view that relies on IE. Please let us know the result!

Regards,

Ana 

Hello Ana, thank you for your Reply. I can successfully login to Atlassian account https://id.atlassian.com using IE11. Trying to finish the installation of SourceTree with the same credentials still failes.

Regards,
Christian

I have the same issue since yesterday with sourcetree 2.2.20.1. I Tried logging into  web portal using IE and it works fine. Looks mor like the application issue. Please help us.

The same problem here. I use IE 11.0.9600 and downloaded the current version 2.1.2.5.1502111015 of SourceTreeSetup.

Please help.

0 vote

Hi

Just to let you know, we are investigating but as yet we've not managed to reproduce the problem.

Any additional information would be very useful. As I understand it the environment is as follows.

  • Win 7
    • 64 or 32 bit?
    • SP1 ?
  • IE
    • All version 11?
  • Are there any proxy servers etc in use?

2.1.2.5 has been out for some weeks, but we seem to have a spate of these questions, has anythign changed in Win 7 land?

Win7 64bit and SP1.

For me it is also Win7Pro 64bit with SP1.

Usually I'm connected to the corporate network and expect that there is something like a proxy. But same problem at home without any proxy. It is also no difference if connected via VPN or not.

BTW: I've used the same installer SourceTreeSetup-2.1.2.5.exe on Win10 64bit without problems.

0 vote
Warren Levy Community Champion Aug 11, 2017

Just to remove the focus on the latest verison of Sourcetree, I initially tried installing v2.1.2.5 and had the same issue as above.

My company had saved the install for v2.0.20.1 so I tried it and got exactly the same issue, so it isn't something with the new version causing this problem, if that helps.

As a temporary workaround, I have successfully installed GitHub Desktop so am able to do all the I need until this is resolved.

Having the same issue on Windows 10. Able to log in via the website on IE. Can't log in via the SourceTree application.

Domain network

Windows 10 1607

Sourcetree 1.10.15.4

Sourcetree 2.1.10.0

IE 11.1480.14393.0

 

Any resolution would be appreciated.

0 vote
Mike Corsaro Atlassian Team Aug 16, 2017

Hello! It looks like the issues are coming from the identity website. We're working with the team to figure out what the problem is.

Same issue here. Windows Server 2016 (Amazon Workspace). We installed it successfully a few weeks ago, now it won't install for anyone.

Looking at a wireshark trace it looks like its fine from a network perspective (http 200 when talking to authentication endpoints).

Same Here , domain network , windows 10, latest source tree 2.1.10.0.
Why you need this window before the program is installed i dont get it
why during the install i tries to download the emmbeded git client without including it with the sourcetree install itself and dont have any proxy settings for it to succed , i dont get it.

Same Issue.

Windows 7 professional - 64 Bit

Login works on IE and Chrome.

Using Corporate or Personal Network.

Trying to install Sourcetree 2.1.10.0

 

Same issue with: Win7 Pro / 64bit / SP1.

Tried with SourceTree versions 2.1.10 and 2.0.20.

Any updates in here?

Same here.

Tried 2.1.10.0, 1.9.9.20 and 1.9.5.0 - same result for evry version.

Is there any workeround until you fix it?

I'm having the same issues as everyone else.  When will this be addressed?

0 vote
Mike Corsaro Atlassian Team Aug 23, 2017

Hello everyone, our identity team is still working on this issue. However, if you're having this problem, could you try changing your Internet Explorer Security Zone Settings?

 

https://support.microsoft.com/en-us/help/17479/windows-internet-explorer-11-change-security-privacy-settings

I changed the security zone settings from high/middle to middle. But the error still appears during the installation.

Confirm. Thanks

I solved it in the following way.

Internet Explorer > Internet Options > General > Browsing history Settings

Set the storage location of temporary files somewhere in the folder.

I have a related problem, with the latest 2.3.1 release.

I just get a white page where the login page is to be shown in the installer.

Fiddler reports that several web requests have succeeded, among them some js/css files.
Right-clicking the window, I can view the source. If I save that source to a physical ".html" file and run that, I can see the login screen, but it doesn't work (obviously).

For what it's worth, I can log in to the web just fine, using IE11 with the same URL that I get from the properties of the blank login page.

I'm under an enterprise regime, and can't change any IE settings. Have tried deleting temp files etc., but no luck.

Hi

we are currently working on this issue. Please see https://jira.atlassian.com/browse/SRCTREEWIN-7244 for updates and workarounds.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

570 views 1 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you