It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Installation fails : Something went wrong while attempting to validate your credentials.

I have been looking for a solution on the community sites for a while to this issue.

I have tried installing versions from 1.9 on ward. Nothing works.

 

None of the solutions seem to work.

Please provide a guide as to what to do.

 

Windows Server 2016.

SourceTree_2.5.5

 

Please help.

Rick Laird

 

2 answers

Successfully resolved this issue on Windows Server 2012 R2.

  1. Added *.atlassian.com to Trusted sites (Internet Properties > Security > Trusted sites > Sites)
  2. Edited the security settings (Custom Level) for Trusted sites to:
  • Enable Access data sources across domains (under Miscellaneous)
  • Enable Allow META REFRESH (under Miscellaneous)
  • Enable Active scripting (under Scripting)


I hope this helps someone else!

It already helped me, less than seven hours later!

In IE 10 on Windows 7, the URL had to be https://*.atlassian.com.

Like Liszt likes this
0 votes
minnsey Atlassian Team May 14, 2018

Hi

I'm assuming you are trying to use the Atlassian account option to register Sourcetree?

As I'm sure you have read elsewhere, that option currently relies on a WPF component that uses IE under the covers. As such it is reliant on the configuration of IE. It is worth checking if you can login to https://id.atlassian.com using Internet Explorer

Best advice as of today for registration issues with IE are as follows:

  1. open Internet Explorer
  2. open the Developer tools, f12
    1. set the Browser Mode 10
    2. set the Document Mode Standards
  3. open Cog/Internet options
    1. ensure the following settings are enabled
    2. Misc/Access data sources across domains
    3. Misc/Allow META_REFRESH
    4. Scripting/Active Scripting

If these still don't work and you cannot login directly via IE, can you post up a screenshot and any errors from within its Developer Tools.

Changing IE Settings worked for me previously, but now our group policy is somehow getting in the way of this.

I was able to make all of the settings you suggested, but I cannot modify the Trusted Sites, and I am unable to log in directly via IE. Here's the response from Debugger:

<!DOCTYPE html><html lang="en"><head><meta charset="utf-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width,initial-scale=1"><meta name="description" content="Log in to Jira, Confluence, and all other Atlassian Cloud products here. Not an Atlassian user? Sign up for free."><meta name="google-site-verification" content="HNNnCkeVQ-w56fqPpX2TTEMRmta5QJ-bDunwoaUep-o"><meta name="apple-itunes-app" content=""><link rel="shortcut icon" href="https://cpfs-cdn.atlassian.com/assets/shared/id-summit/id-summit-aa-favicon.ico"><title>Log in with Atlassian account</title><style>.scriptLoadError{display:flex;align-content:center;background-color:#0747a6;position:absolute;top:0;left:0;width:100%;height:100%;font-size:14px;font-style:normal;font-weight:400;line-height:1.42857142857143;letter-spacing:-.005em;font-family:-apple-system,BlinkMacSystemFont,Segoe UI,Roboto,Oxygen,Ubuntu,Fira Sans,Droid Sans,Helvetica Neue,sans-serif}.scriptLoadError .container{color:#fff;margin:0 auto;align-items:center;display:flex;flex-direction:column}.scriptLoadError .content{background:#fff;border-radius:3px;box-shadow:0 10px 10px rgba(0,0,0,.1);box-sizing:border-box;color:#172b4d;padding:48px;width:400px}.scriptLoadError .content{margin-top:48px}.scriptLoadError .content p:first-child{margin-top:0}.scriptLoadError .content a{text-decoration:none;color:#0052cc}.scriptLoadError .logo{margin-top:48px;margin-bottom:0;font-size:40px;line-height:48px}.scriptLoadError .heading{color:#deebff;font-size:24px;font-weight:500;line-height:28px;margin-top:48px}</style><link href="https://common-admin-cdn.atlassian.com/atlassian-id/front-end/2.5.20/static/css/main.643280c9.css" rel="stylesheet"></head><body data-app-state="{&quot;csrfToken&quot;:&quot;3c682aa858094d0c20cbedfeca73a31b6e161352&quot;,&quot;microbranding&quot;:{&quot;isEmbedded&quot;:&quot;false&quot;},&quot;featureFlags&quot;:{&quot;aid_signup.3pc.disabled&quot;:false,&quot;aid_signup.marketing.consent&quot;:false},&quot;appConfig&quot;:{&quot;contextPath&quot;:&quot;&quot;,&quot;auth0Config&quot;:{&quot;clientId&quot;:&quot;tDP5by46cc3gEck7d2vbHZsqsfrDK6t9&quot;,&quot;tenant&quot;:&quot;atlassian-account-prod&quot;,&quot;domain&quot;:&quot;auth.atlassian.com&quot;,&quot;tokenIssuer&quot;:&quot;https://atlassian-account-prod.pus2.auth0.com&quot;,&quot;callbackUrl&quot;:&quot;https://id.atlassian.com/login/callback&quot;},&quot;isSamlEnabled&quot;:true,&quot;recaptchaKeySite&quot;:&quot;6LewHQcTAAAAAJgaYVKlQOahz4gnQME8wqUA0z0J&quot;,&quot;segmentIoKey&quot;:&quot;cb2egpwag7&quot;,&quot;bitbucketSignupUrlOverrideEnabled&quot;:&quot;false&quot;,&quot;sentryUrl&quot;:&quot;https://71e54c28be0d49f0bcd732ab30f35faa@sentry.io/275199&quot;,&quot;recaptchaEnable&quot;:true,&quot;bitbucketSignup... id="root"><noscript><div class="scriptLoadError"><div class="container"><h1 class="logo">Atlassian</h1><div class="heading">JavaScript is disabled</div><div class="content"><p>You should enable JavaScript to work with this page.</p></div></div></div></noscript><div id="javaScriptLoadError" style="display:none"><div class="scriptLoadError"><div class="container"><h1 class="logo">Atlassian</h1><div class="heading">JavaScript load error</div><div class="content"><p>We tried to load scripts but something went wrong.</p><p>Please make sure that your network settings allow you to download scripts from the following domain:</p><p><b>https://common-admin-cdn.atlassian.com/atlassian-id/front-end/2.5.20</b></p></div></div></div></div></div><script>var mfaServerUrl="",ticket="",requestToken="",postActionURL="",userData={userId:"",email:"",friendlyUserId:"",tenant:"",tenantFriendlyName:""},globalTrackingId="";window.onload=function(){document.getElementById("javaScriptLoadError")&&(document.getElementById("javaScriptLoadError").style.display="block")}</script><script type="text/javascript" src="https://common-admin-cdn.atlassian.com/atlassian-id/front-end/2.5.20/static/js/main.e9684a94.js"></script></body></html>

minnsey Atlassian Team May 24, 2018

Hi

To be honest you might be stuck for the moment.

The registration process is an are we continue to review, but for now you need to be able to either register against a Bitbucket Server instance or against Atlassian account which uses the IE component.

Sorry I can't be more help at this time, but please watch this space.


Michael:

I'm glad Atlassian folks are reading and repsonding to these. 

I was finally able to get working again by completing the installation with a Google account, and then adding the Atlassian account from [Options] once I could get the shell loaded. 

Our network folks removed me from the group policy and then I was able to log into the website id.atlassian.com from within IE (which I couldn't before), but I was still unable to complete the installer with an Atlassian login. Please fix this, it's a huge hassle for our team. 


Andy

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,962 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you