Installation: Blank window appear for "use existing account"

During the installation process there is the checkpoint "Atlassian Account". If I click on "use an existing account" only a white window is opened. I cannot select anything. It is just a blank window. I'm working on a Windows 10 machine with admin permissions.

I already tried some suggested solutions (reset personal settings of IE, lower security level of IE) but nothing helped so far.

How can I solve this problem? 

Best regards,

Tobias

7 answers

1 accepted

0 votes
Accepted answer

Hi everyone, there's a new workaround listed at SRCTREEWIN-7244:

From a working install collect the accounts.json and passwd files.

Delete the Atlassian folder from the AppData/Local directory for your user. Run the installer for 2.3.1, close it when you get the blank login window. Place the account.json and passwd files into the Atlassian/SourceTree folder. Rerun the installer. It should detect the account and password from those files and bypass the request for a login.

Please give it a try and let us know if it works for you!

Best regards,

Ana

I was having this issue with my work laptop. i have a good installation at home. Remoted into my home computer and grabbed the listed files from my home computer, downloaded 2.3.1 installer. Delete the Atlassian folder from AppData, ran the installer and closed, copied the files in (Locations Listed Below), and then reran the installer. I was able to proceed with the installation. Thank you so much @Ana Retamal Ortiz. I love SourceTree and have been using GitHub Desktop for a few weeks now at work and hate it. It does not have nealy as many feature as SourceTree does.

Delete This Folder

%USERPROFILE%\AppData\Local\Atlassian

Run Installer, get blank login screen, close installer

Copy accounts.json and passwd file to this folder

%USERPROFILE%\AppData\Local\Atlassian\SourceTree

Rerun installer. For me it prompted me about a Git Installation and I continue on through the installation.

0 votes

Hi Tobias, have you installed all of the Windows 10 updates? There was another user with the same issue and that solved the problem for him.

Can you also check if you're able to log into https://id.atlassian.com using IE? It has to be tested via Internet Explorer because the WPF Web View component Sourcetree uses relies on Internet Explorer under the covers.

Are you using any firewall or proxy?

Regards,

Ana

Hi Ana,

thanks for your fast reply.

Concerning the windows 10 updates, I'm dependent on our IT-infrastructure department since I'm working in a company-network. However, I installed all updates which are available.

Unfortunately I cannot connect to my account using IE. As I mentioned, I already found the IE related suggestions and tried them (reset personal settings of IE, lower security level of IE) but nothing worked so far.

I do not use a proxy. I'm not sure about the firewall but my colleagues have no problem in using Sourcetree (and  they did not experience any of my problems). Therefore I do not think that it is a firewall which is blocking me (I also have no problems in connecting to external DBs etc.)

Regards,

Tobias

Have you also tried turning off Compatibility mode in Internet Explorer (as it blocks the authorization page)? You can find the instructions here.

Also, this issue has been reported at SRCTREEWIN-7949. You can leave your commetns there and I also recommend you watch that bug ticket to get notifications about any updates or workarounds that might arise.


Cheers,
Ana

Ran into same error of blank window during install "Use an existing Account" after changing the default browser to internet explorer and then changing compatibility view settings on IE it worked.

Hi,

thanks for all the suggestions. Unfortunately, none of them worked so far. However, while turning off the compatibility mode, I'm able to log into  https://id.atlassian.com via IE.

It is a really annoying issue. 

I don't know exactly what happend but it works now.

First I tried the workaround posted by @Ana Retamal Ortiz. Unfortunately, it is not very specific (regarding where exactly to place the mentioned files), although another user posted how the accounts.json should look like.

However, I started with the fix and when I reached the account question , where I always got the aforementioned blank screen, I got the correct login screen.

For me it seems like it did not work before because I made the changes to the IE but did not uninstall/delete the Sourcetree installation. It does not sound logical but because I did nothing else but to delete and reinstall this seems to be the fix in my case.

To summarize, my suggestion is:

- make compatibility changes to IE as suggested by @Ana Retamal Ortiz

- set IE to default internet browser

- uninstall/delete current SourceTree installation (if present) (Users/yourUser/AppData/Local/SourceTree)

- install SourceTree again (blank screen is replaced by correct login) 

any one tell how to find password and json.account files

%USERPROFILE%\AppData\Local\Atlassian\SourceTree

I was able to solve it by adding https://*.atlassian.com to trusted sites in IE (Internet Options -> Security -> Trusted Sites)

It worked on Win10 and win. server 2012

Delete This Folder

%USERPROFILE%\AppData\Local\Atlassian

Run Installer, get blank login screen, close installer

Copy accounts.json and passwd file to this folder

%USERPROFILE%\AppData\Local\Atlassian\SourceTree

Rerun installer. For me it prompted me about a Git Installation and I continue on through the installation.

Hi,

I was also facing same Blank screen issue. I was initially trying from user (Non Admin) in Windows 10. I was not able to succeed in any options.

I tried by logging in as Admin and installed the same. Then I was able to login as an Existing Account.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

831 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you