Install SouceTree for Windows without admin rights

Is there a way to install SourceTree for Windows without admin rights? I tried choosing a folder the user has write access to as the installation target, but the installer still requested admin rights.

8 answers

This widget could not be displayed.

I do have the same issue.  At my company developers do not have admin rights.  And since the latest Windows 10 update we can't even modify account level information.  If software requires admin rights to user or install we typically aren't allowed to use it.  Before this I hadn't realized you can't even write to Program Files without admin authority.  I tried installing SourceTree to a different directory but as soon as it tries to request admin access it craps out.  I know Microsoft built this process but we just don't always have access to these areas of our machine. So we end up with both Microsoft and our own company standing in our way.  There should always be a "non admin" method of installation and use of software on a windows machine.

This widget could not be displayed.

I believe you can choose the installation folder during the install process. Did you try to do that? What happened?

This widget could not be displayed.

Yes, I chose another destination folder where I have write access but it still asks for admin rights. And I don't have an admin account :(

This widget could not be displayed.

Ok, thanks for the additional info. I've edited your question to include that. If you don't get a useful answer in a few days, you may need to submit a feature request at http://jira.atlassian.com

This widget could not be displayed.

Ok. Thanks a lot! I will file a feature request soon.

This widget could not be displayed.

Hi. I am having a related issue. I have tried all mentioned above but no luck. Each time I pull from sourcetree It prints the following and the number doesn't change of items to pull that is: 0 [main] sh 11300 handle_exceptions: Exception: STATUS_ACCESS_VIOLATION 255 [main] sh 11300 open_stackdumpfile: Dumping stack trace to sh.exe.stackdump git -c diff.mnemonicprefix=false -c core.quotepath=false submodule update --init --recursive Completed successfully. Any idea on how to fix this one. Have tried all. The on thing that seems to work is pull with a rebase but then again it's a tedious process

This widget could not be displayed.

@Lenon Marumbwa Sounds like a different issue to me. You should post a new question.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

858 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you