Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Incorrect Git-Flow Warning?

I'm using Sourcetree 2.6.10 for Windows. When I launch the application I get a warning telling me that Git-flow is not supported and that I should upgrade to Git 2.17.1.2.

Under Tools/Options/Git the application shows that I'm using Embedded Git version 2.17.1/LibGit2Sharp 0.24.0 + git-lfs v2.4.2 so I don't understand why I'm getting the warning.

Is there something more that I need to do?

 

3 answers

0 votes
minnsey Atlassian Team Jul 20, 2018

Hi

It is possible that this is a bug.

Sourcetree used to bundle its own copy of git-flow, we recently changed that to rely on the version that is now bundled with Git for Windows. As part of that there are 2 types of notification:

  • Sourcetree can't find git-flow
    • (implying the Git install is an old version that doesn't include git-flow)
  • Sourcetree can find git-flow but it is too old
    • (implying the Git install does bundle git-flow but it is an old copy)

If the git-flow button and actions are working then this is just an issue with the notifications.

Can you confirm the exact notification message?

Thanks

Well, of course it's not showing the notification now! I seem to recall that the notification comes and goes but can't be sure.

Like servis_maisondidee likes this

The Notification/warning is back again today. The exact message text:

Git-flow

Git-flow not supported

You'll need to upgrade to Git 2.6.4 or later.

We recommend upgrading to Git 2.17.1.2.

Learn more

Thanks for confirming, we will review its operation

My opinion is the warning is invalid.   I installed 2.18.0 of GIT and it states that in SourceTree and I still get the error.   

0 votes

Hi

can you try the latest version (3.3.0+)?

We've fixed GitFlow version gathering routine.

Where is 3.3.0+ available? The latest version on sourcetreeapp.com is still 3.2.6.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,251 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you