In SourceTree, the Accounts in "View--Options--Network" section are messed up Edited

My Git repositories on the corporate network rely on SSO and our passwords change very often. Usually, I was able to use the "Options-->Authentications" option in SourceTree to simply update my password.

However, with the recent update in 2.x, the user interface has changed for worse and I am unable to change my password. Even after I set the password, SourceTree says access denied for the repository under consideration even though I can connect to that repository just fine using git on command-line. I tried deleting all my accounts in SourceTree but it still keeps an account permanently in there despite clicking "Delete".  What is worse, SourceTree is NOT allowing me to configure SSH-based repositories.

I am at a point where I am considering moving away from SourceTree because of this problem. Ever since I upgraded to 2.x, the user interface has become extremely non-intuitive and frustrating.

How do I completely get rid of all my accounts in SourceTree and configure new ones that allow me to access the repositories on my corporate network using SSH. The user interfaces forces me to select between BitBucket and GitHub; neither of which apply in my case.

The specific error that I am seeing is (I have not  changed any configuration in SourceTree):

Access denied
FATAL ERROR: Server sent disconnect message
type 2 (protocol error):
"Too many authentication failures for MY_USER_NAME"

1 answer

0 vote

Hi

Sounds like you are using SSH with a self hosted, or non Bitbucket/Github server, are you using SSH with keys or with username/password?

Thanks for the reponse Michael. Our repositories are hosted locally on a host on the Intranet and so is the user account (on Linux hosts) that is accessed only via SSH. I'm no security expert so pardon my lack of the use of proper terms.

I had configured SourceTree in the past to rely on Putty instead of OpenSSH because that was offered as the recommendation when installing SourceTree. I also remember having generated the public and private keys when installing SourceTree. I tried reimporting the keys to no avail to fix the problem. In the versions prior to 2.x, all I had to do was go to the Tools-->Options-->Authentication tab and update my password for the user account that was used for my repositories.

When I try to use the "Terminal" from within SourceTree and do a "git pull" or "git push", I am prompted for my password and upon entering the password, I am able to work. However, when using the Pull or Push from the SourceTree user interface, it throws the "Access Denied" errors.

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

270 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot