It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Ignored File does not appear in .gitignore.

Hi there- I've right-clicked on a particular file in sourcetree and set it to 'ignore', and I'd like to revert that, but the file doesn't show up in my .gitignore file either.  Any idea what might be happening here?

1 answer

1 accepted

1 vote
Answer accepted
Ana Retamal Atlassian Team Sep 04, 2019

Hi Morgan, welcome to the Community.

Most likely, the file got added to global .gitignore and not the local .gitignore.

When you choose to ignore a file that is modified etc, SourceTree should bring up a dialogue where you can choose either of them. Can you check the global .gitignore file and see if it's there?

To remove a file that you have added by accident, navigate to Sourcetree > Preferences > Git menu option. 

Hope that helps! Let us know if you have any questions,

Ana

Hey there Ana-  Thanks for the tip!  I must have selected the global option by mistake and got confused.  I found the global .gitignore in my home directory and editing that did the trick.

Cheers, Morgan

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,935 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you