Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I'm unable to fetch or pull.

After routine Fetches and Pushes earlier this week; yesterday, I was no longer able to Fetch. I tried several times over the course of the day, re-entering my password many times. 

This morning, still unable to Fetch, I logged onto Bitbucket to ensure there would be no conflicts if I tried Pushing two Commits instead. When I did so I received the following:

//////////////////////////

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks push -v --tags origin master:master

fatal: TaskCanceledException encountered.

   A task was canceled.

//////////////////////////

I only cancelled the interminable failed Fetches from yesterday and this morning as well as the Push after seeing the full output above.

I'll still a newbie at Bitbucket, but I'm much more relaxed now. I'm using Sourcetree version, 2.6.10.0. Your guidance is greatly appreciated; I was last rescued by Atlassian Support on 10 August last month, BBS-85316. 

1 answer

1 vote
minnsey Atlassian Team Oct 04, 2018

Hi

I think this might be an issue with the Git Credential Manager whihc looks after credentials for Git for Windows.

I'd suggest installing Git 2.19 and switching Sourcetree to use it as a System Git install in Tools/Options/Git tab

Hi Michael, Thanks for the reply. I realize there was a big Sourcetree change taking place when I posted my question on Friday; I felt I could wait a week or two before my problem would become critical. I was ready to start reloading applications when everything started working again. 

Your recommendation -  installing Git 2.19 and switching Sourcetree to use it as a System Git install - is at the top of my to-do list if my problem returns.

Thanks again,

Robert 

It's a week later. I had additional problems so I installed Bittbucket 2.19. How do I make it my system GIT install? The Sourcetree Tools/Options/Git tab shows the System Git version is 2.19.1. I checked the “Allow Sourcetree to manage my credentials via the Credential Manager’ box. I have the credential manager open elsewhere, but I have no existing or new Bitbucket credentials. Now when I tried to Fetch I get many repetitions of:

/////////////////////

fatal: ArgumentException encountered.
An item with the same key has already been added.

remote: Invalid username or password
fatal: Authentication failed for 'https://bitbucket.org/...'

/////////////////////

(I added the '...'). I tried Fetching again with the credential manager box unchecked. No change. I tried rebooting and restarting with no joy. Any assistance is appreciated. 

Like Deleted user likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,319 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you