Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

  • Community
  • Products
  • Sourcetree
  • Questions
  • I keep getting this message “SourceTree” is damaged and can’t be opened. Delete “SourceTree” and download it again from the App Store.

I keep getting this message “SourceTree” is damaged and can’t be opened. Delete “SourceTree” and download it again from the App Store.

I keep getting that message, I have removed ~/Library/Application Support/SourceTree and /Applications/ and reinstralled and still get that message.

What should I do?


7 answers

1 accepted

1 vote
Answer accepted
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Feb 03, 2013

Hi Juan,

This is usually caused by the being modified. I've just tested this myself direct from the App Store and it worked fine. Do note that we no longer publish updates to the App Store (this happened very recently) due to sandbox restrictions so it's better to get it direct from Perhaps try the direct download first, and if that doesn't work if you could answer the following:

  • Which browser did you use to download it?
  • What OS version are you using?
  • Which version of SourceTree was it?

Many thanks

It's 2016 and this issue is still not resolved.. I was using Sourcetree just fine yesterday and now it's damaged or incomplete...

same issue for the second time. intall again fix it

Yes, same here. Replacing the ~/Applications/ with a fresh one fixes it for me. But ... I've done this already two times in a single week.

Same situation. Atlassian, please fix Sourcetree!

It works perfectly fine eveywhere but your global applications directory. (Works when I copy the app to ~/Desktop or ~/Applications, but getting the same "is damaged and can't be opened, when I try to open it from /Applications). Fix it maybe?


I am getting this error now as well.. I've not done anything to modify the .app file. I have been using it daily for some time, and went to open this morning and got the message

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events