Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I do enter my valid username and password but it through the error belove.

Command: git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks ls-remote https://github.com/Deva2002/Airlines.git
Output:
Error: remote: Invalid username or password.
fatal: Authentication failed for 'https://github.com/Deva2002/Airlines.git/'

 

2 answers

0 votes

What happens if you try the git command on the command line (outside Sourcetree)?

I am not the OP, but have exactly the same error. When I copy/paste the command into the command window it works. It asks me for user name and password and I use the exact same ones I have set up in SourceTree 3.4.2. I have removed and re-added the credentials several times. Usually, I would just type it both places but to absolutely ensure it isn't a typo I have gone through the sequence a couple of times using Google password manager as the source to copy/paste the password. Absolutely using the same username/password combo.

EDIT - It is SSH in both cases, but I have also tried HTTPS

I have the same error. It seems that this is because GitHub does no more accepts the "old" authorization method.

Unfortunately, I don't know if it is possible to change this in SourceTree...

I get the error with BitBucket, which makes it all the more frustrating. I know it's an open protocol, but SourceTree is more or less the "native" front end for BitBucket.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

3,723 views 19 19
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you