Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,465,034
Community Members
 
Community Events
176
Community Groups

I cannot pull/push with sourceTree but I can login fine in bitbucket.

I tried to generate App password on Atlassian and used that.  Then I went to sourceTree Options/Authentication and I click to refresh password. Entered that generated password and it said Athenticated! Then I go to pull and it failed.  This used to work with a previous version of sourceTree!

It fails even if I put in my Atlassian password!!  

2 answers

0 votes
Michał S I'm New Here Dec 10, 2022

On bitbucket.org go to left panel and click Personal Preference. In Left panel then click App Passwords.  Create your password.

Go back to SourceTree and in the SourcePath paste "https://USERNAME:APP_PASSWORD@bitbucket.org/workspaceID/reposlug.git". Where USERNAME is your bitbucket username and the APP_PASSWORD is the password you have generated in previous step.

This worked on my Windows, after 2h fight :(

0 votes
Ben Atlassian Team Dec 06, 2022

G'day! 

Thank you for contacting Bitbucket Cloud Support.

The most common issue customers are experiencing related to authentication in SourceTree is due to the deprecation of GIT username/password in favour of App Passwords:
https://bitbucket.org/blog/deprecating-atlassian-account-password-for-git-and-bitbucket-api-activity
We have a blog post however which explains the steps to troubleshoot this issue, please follow all of these steps accordingly (including uninstall/re-install) and this should resolve the issue:
https://community.atlassian.com/t5/Sourcetree-articles/Bug-Fix-Sourcetree-for-Windows-authentication-error-when/ba-p/1965968

 

When you are authenticating GIT over HTTPS to push/pull you will need to update your remote URL's to include the AppPassword:
git remote set-url origin https://USERNAME:APP_PASSWORD@bitbucket.org/workspaceID/reposlug.git
The same applies when performing git clone:
git clone https://USERNAME:APP_PASSWORD@bitbucket.org/workspaceID/reposlug.git
I would suggest ensuring also that all stored passwords related to authentication over GIT are cleared from your machine (ie Credential Manager for Windows, Access Keychain for Mac or /etc/shadow folder for Linux).

Cheers!

- Ben (Bitbucket Cloud Support)

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events