Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,911
Community Members
 
Community Events
176
Community Groups

I can't open iTerm with sourceTree

mac: 10.15.1 Catalina

SourceTree: 4.0(232)

I used to click 'open iTerm' button and it worked always. But it didn't work yesterday. I can open Finder, but not iTerm. I don't know why. 

First I kill iTerm, then click 'open iTerm' button, my iterm opened, but not my path, it's '~/'.

Maybe I set something wrong, anybody know it?

2 answers

1 accepted

6 votes
Answer accepted

Download sourcetree(other version like 3.2.1), and open it.

Allow permissions.

Then upgrade to 4.0

Thank you. It worked for me!

Like ultimate-deej likes this

This worked for me, too! Thank you!

I tried updating to 4.0.1 and also compared my macOS Security & Privacy settings before and after @GreatPeng's tip, but I couldn't find any difference. So this weird workaround seems the only way to make it work until Sourcetree is fixed.

This worked for me also, thank you!

For those coming from Google: the download link for 3.2.1 can be found here.

Like # people like this

I don't see an 'Open iTerm' button in either version... where is that?

Just 'Terminal' which is the less nice Mac native terminal.

I have iTerm2 set as my default terminal but, Sourcetree does not use it. Would be nice feature if we could pick! ;) 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events