Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I can't open iTerm with sourceTree

mac: 10.15.1 Catalina

SourceTree: 4.0(232)

I used to click 'open iTerm' button and it worked always. But it didn't work yesterday. I can open Finder, but not iTerm. I don't know why. 

First I kill iTerm, then click 'open iTerm' button, my iterm opened, but not my path, it's '~/'.

Maybe I set something wrong, anybody know it?

2 answers

1 accepted

5 votes
Answer accepted

Download sourcetree(other version like 3.2.1), and open it.

Allow permissions.

Then upgrade to 4.0

Thank you. It worked for me!

Like ultimate-deej likes this

This worked for me, too! Thank you!

I tried updating to 4.0.1 and also compared my macOS Security & Privacy settings before and after @GreatPeng's tip, but I couldn't find any difference. So this weird workaround seems the only way to make it work until Sourcetree is fixed.

This worked for me also, thank you!

For those coming from Google: the download link for 3.2.1 can be found here.

Like # people like this

I don't see an 'Open iTerm' button in either version... where is that?

Just 'Terminal' which is the less nice Mac native terminal.

I have iTerm2 set as my default terminal but, Sourcetree does not use it. Would be nice feature if we could pick! ;) 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

5,006 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you