How to solve "Too many invalid password attempts" error?

Hi,

I started using SourceTree mac version with BitBucket account a few months ago. Since the first day I constantly saw the following error message when doing any git related tasks:

git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree fetch upstream

remote: Too many invalid password attempts. Try logging in through the website with your password.

fatal: unable to access 'https://yz@bitbucket.org/myrepo.git/': The requested URL returned error: 403

Completed with errors, see above

 

I've tried searching for solutions but had no luck. Some old threads mentioned it's a server side issue and was solved. 

Current workaround is to go to Accounts and log in again everytime the error pops up.

Lately the error pops up more often than usual. Could you help me with this?

 

Thanks!

 

 

 

 

 

 

21 answers

This widget could not be displayed.

Hi Yuli, have you already tried login into Bitbucket using the web interface?

If after that you're still getting the error, navigate to id.atlassian.com in your browser with your email, and password - please make sure to NOT use the Google login form, and instead use the basic email/password fields. You may be asked to go through a captcha screen, or even reset your password if necessary.

Once you get logged in properly to id.atlassian.com, try your GIT operations again and please let us know if the issue is solved for you.

Best regards!

Ana

 

Hi Ana,

Thanks for the solution! It works so far. 

 

Logging into id.atlassian.com didn't do anything for me - still seeing the 403 errors from sourcetree.

This was only on the Sourcetree UI, after a recent update to 2.1.10.0.

git pull from command line works fine.

I've the exact same problem.

 

Any solution?

going to id.atlassian has unfortunately not helped 

only 1 other person says it worked is there a particular browser that will help . I have authenticated with both chrome and IE 

Sometimes it works and sometimes it doesn't. Its more of a constant bandaid that you have to do all day in order to use SourceTree. Do you only have the option to login using a gmail account as well? I can confirm that when I could add my account over basic https, this never happened but that isn't the case anymore and that is not an option (only OAuth via google).

After logging to id.atlassian.com I got new errors, but operation is complete.

git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree fetch origin
remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.
fatal: Authentication failed for 'https://myusername@bitbucket.org/myusername/service-desk.git/'


git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree pull --no-commit origin master
remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.
fatal: Authentication failed for 'https://myusername@bitbucket.org/myusername/service-desk.git/'
From https://bitbucket.org/myusername/service-desk
* branch master -> FETCH_HEAD
Already up to date.
Completed successfully

Seems like this issue has been there for quite a while now. I recently started getting this error within the last month or so - seems like it started to happen after I updated to the newest version of Sourcetree.

Any news on a fix for this? Git from the terminal in macOS (High Sierra) works perfect, I just prefer a UI, but I'll have to switch from Sourcetree if this doesn't get any attention soon ;-\

I've tried all the solutions suggested and nothing helps...

This seems to be the normal procedure from you guys when something breaks - radio-silence for a very long time and then developers start to find other tools instead of your stack as it's filled with flaws... getting really tired of it.

Same here. Updated to newest version of Sourctree (2.7.3) and am getting constant  issues of the type:

remote: Too many invalid password attempts. Log in at https://id.atlassian.com/ to restore access.

 

I do not want to login after every pull/push I want to make. This is simply a major headache for the users.

A bug who has been living for so long, who would say :( I'm done, looking for another software until this isn't sorted out

@Bruno Cunha have a look at Manjunath Basaralu Srinivasa's reply to Ana Retamal Ortiz's post below. There's a link to a beta version, that fixes the issue - it does for me at least.

Give it a try and see if it works for you.

Just to confirm the bug is fixed on version 2.7.4 (174) and I'm happy to use Sourcetree again. Good job guys

It's broken again in 2.7.6. Very frustrating. I can clone and do all operations by hand with a ssh key, but nothing with SourceTree.

Yes. 
Still busted here!
Using 2.7.6 on High Sierra. 

I am deleting the stored password in KeyChain,  before each Push attempt, to insure I can potentially avoid the "too many invalid attempts". Then I enter the password I use to login into my Atlassian account. 


But yes, no luck!

AmitSuri I'm New Here Aug 17, 2018

Git Embedded is the one broken. Using system version of Git and the password problems are fixed for me.

This widget could not be displayed.

Same here... it's been like this since i installed it a year ago, but it got worst on the latest updates... Do something...

This widget could not be displayed.

Hi everyone! I've reached out to our Sourcetree developers regarding your concerns, and they informed me that there's a fix coming for this in 2.7.4. If any of you is interested in trying an early access build and confirm the fix, let us know!

Best regards,

Ana

Please find the direct download link for the 2.7.4 beta which includes a fix for this issue - https://bitbucket.org/atlassianlabs/sourcetree-betas/downloads/OSX_Beta_Latest.zip

Kindly provide feedback if you see any issues with respect to "https" authentication with Bitbucket which returns 403 errors. 

Thanks,
Manjunath
Sourcetree Mac Developer 

Hi @Manjunath Basaralu Srinivasa - I just tried out the beta and seems to be working, but I'll have to try it out for some days I believe, because it seems like the issue sometimes disappear for a while after resetting my account settings (re-connecting my user through SourceTree).

I'll give it a spin for a few days and return with my findings - thanks for your help so far :-)

Absolutely. Appreciate the help with this. 

Cheers!

Hi,

when do you plan to publish an official update that includes this fix?

Thanks,

Dusan

Hi @Manjunath Basaralu Srinivasa - I've now tested out the beta version in regards to the issue with authentication and everything seems to be working nicely. I didn't have any of the issues that were reported.

However there was a new beta release which I've downloaded now and the release notes doesn't mention anything about changing anything in relation to authentication, so I'm guessing it's safe to say, that it won't affect anything related to authentication right?

Its absolutely safe. The latest update does not have any authentication related changes. Also, these changes are out of beta and we have started rolling it out in the regular channel for everyone. 

Is there a newer Version for windows?  I am constantly having this issue, either wrong password or too many failed login attempts.  I changed my password twice, cleared my windows credential store, reinstalled source tree.  I have no problems logging into the website online or validating my credentials.  Spent 3 hours tonight trying to fix this tonight :(

Mike Corsaro Atlassian Team Jun 14, 2018

Hello! Could you try downloading 2.6.6 and see if it solves your issue? Thanks!

Mike! this fixed the problem, thanks so much!

This widget could not be displayed.

I switched to GitGraken a few months ago and it is hands down a better application. None of these issues, has a better UI and is super easy to use. At some point, you gotta say enough is enough and just move on from SourceTree.

You're right! Sourcetree is not the only one. But I'm that guy that's getting used to things ;) The next time I'm gettin' these problems I will switch to GitGraken. 

I'm a huge Atlassian fan, but sourcetree is just not a good tool anymore for google only logins. Its broken and its been broken for around a year...having this EXACT issue and they haven't resolved it. GitGraken does not have this issue at all. It was just time to move on for *me* and I got sick of constantly having to re-log in whenever i wanted to commit.

This widget could not be displayed.

I'm experiencing exact the same problem.. Every 2 or 3 commits I have to login on id.atlassian.com to work around this problem..

Was getting this as well, however the id.atlassian.com fix was not working fro me at all. I added my Bitbucket account into SourceTree and voilá I was able to connect and push.

This widget could not be displayed.

I am still getting this problem as well. I can't access my repos over HTTPS now, even if I enter the correct password. Is there a real fix for this? I've added my account to SourceTree and I still can't access over HTTPS.

This is getting very tedious.

This widget could not be displayed.

I'm having the same issue now. I can't access my repos at all through Sourcetree. I have:

  • Logged in to atlassian, as requested
  • Validated with two-step authentication through Sourcetree (it takes me to Atlassian, says I'm good)

And just keep getting denied with too many invalid passwords. 

What is up? I AM logging through the company's third party service, and it says I need to ensure I have an account password in my profile... where is that? No idea... I know it worked last week. 

Please help!

This widget could not be displayed.

I'm having this issue as well again. I had it at my previous company and now at this new company I am at. The common theme is they both use google for authentication. Every few git operations (sometimes EVERY operation) returns a 403 and I can navigate to id.atlassian.com (must be EXACTLY this URL) and it'll log me in and i MIGHT be ok for a few more git operations. I have my bitbucket account in sourcetree via OAuth and there is no way to log in without using my gmail account. I have no idea what is up and this is EXTREMELY frustrating and time consuming to have to constantly do this operation. 

This widget could not be displayed.

FWIW, I am also experiencing this issue and it's getting very tedious. Sourcetree on a Mac... account is added to Sourcetree. First time after logging in commit/pull works OK, but then at some random point later, it will fail again. Logging in again is OK.

Is there potentially any correlation with having Sourcetree open on a different Mac (same configuration as above) both committing / pulling from the same repos using the same credentials?

This widget could not be displayed.

Same problem here

Yes, me too. I have reset passwords, reset ssh keys, done two-factor authentication .... but SourceTree won't let me in. " remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile. fatal: Authentication failed for ...."

Help!

This widget could not be displayed.

After upgrading Sourcetree the problem never occured.. So maybe that's the solution?

I am running the latest version of ST so that's not an option for me ....

Ok, did you provide your credentials again in Sourcetree? Re-configure you accounts, so your login session will expire or something like that.

I deleted my account in ST and set up a new one, reset my password in bitbucket, set up a new ssh pubkey ... 

Hmm okay, maybe Chris Reese's advice is the simplest solution. Get GitGraken..

Yep, thanks everyone. I installed GitKraken and it connected immediately.

Nice :) I'm gonna test it tomorrow :)

This widget could not be displayed.

Same issue, fighting it with several options suggested on the Internet, for about a week without any result.

Unless you're just stuck using it, I would switch to GitKraken as soon as you can. I loved sourcetree, but its been over a year and this same problem exists.

Thanks, Chris. I've managed to down-shift to command-line Git and my life is now much better :D

This widget could not be displayed.

GitKraken it is...

This widget could not be displayed.

I have same issue. I can not fix it via browser login either.
I logged in via Sourcetree on Mac (Preferences => Accounts, *select account* => edit, Connect Account => *it opens log in form* => follow the login workflow.

Now it works.

The only question is for how long it works.
Fixed the issue before, but it has reoccured, so it is just a temporary fix

This widget could not be displayed.

Struggling with the same issue. Resetting the password at https://id.atlassian.com/ only fixes the problem temporarily. Very annoying.

This widget could not be displayed.

Still the issue exist, sounds like no way to work with source tree once again, even after resetting the password , it give invalid login error.

This widget could not be displayed.

this issue is still there.
cant login and even if i login to atlassian.id i cant push. So now i'm stuck.

This widget could not be displayed.

Also having this issue with Sourcetree 2.6.10.0

This widget could not be displayed.

having the issue with sourcetree 2.6.10

I'm pissed with this issue i am connected with google, i can't change because it is a professional one and everyone else in my team seams to work properly but me it doens't work. I  tried changing my password in google but it didn't do anything in sourcetree. 

This widget could not be displayed.
  1. Logged in on web browser. Check
  2. Logged out of web browser and back into web browser with standard auth form. Check.
    Thus resetting the notification to login to id.atlassian.com in ST
  3. Opened [Remote] tab in SourceTree and [Refreshed Oauth Token]. Check.
  4. Hit [Fetch] in ST, it opens a dialog to login. The dialog looks different than I remember, but it's a login dialog. I login, with the same EXACT user/pass combo that works in the browser...... FAILURE
    I even tried the username version (since you changed from user to email requirement few months back) -- no dice.
    It continues to do so, and reverts back to #1. Despite valid credentials and all other auth approaches working.

Explain to me what the fuck 

Man screw this, I'm switching to GitKraken. gg

 

FYI.. git clone on command line is failing too. This problem is 100% with Atlassian. 

The fact that it pops up with their dialog when you try to clone from command line proves they are forcing in some "magic" into the pipeline they shouldn't be. 
And the fact that it says: 

fatal: ArgumentOutOfRangeException

followed by manually typing password into command prompt, resulting in: 

remote: Invalid username or password 

proves that their REMOTE service is screwed up, and so is the LOCAL app.

Mike Corsaro Atlassian Team Aug 15, 2018

This is an issue with the git credential manager. 

Download 1.17.1 here: https://github.com/Microsoft/Git-Credential-Manager-for-Windows/releases/tag/v1.17.1

Zev Lopez I'm New Here Sep 07, 2018

This solved it for me.

This widget could not be displayed.

This error almost makes this software unusable. 

I've had to remove all https repos from my machine.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

873 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you