How to solve SSL certificate problem with git-svn

Dear members.

Does anyone know to solve this problem?

I tryied to execute

git config --global sslVerify false

I still got same error.

Thank you for your advice.

Sincerely.

git -c diff.mnemonicprefix=false -c core.quotepath=false svn rebase 
Error validating server certificate for 'https://svn.forgerock.org:443':
 - The certificate is not issued by a trusted authority. Use the
   fingerprint to validate the certificate manually!
Certificate information:
 - Hostname: svn.forgerock.org
 - Valid: from Sun, 03 Feb 2013 16:59:17 GMT until Tue, 04 Feb 2014 14:54:36 GMT
 - Issuer: Secure Digital Certificate Signing, StartCom Ltd., IL
 - Fingerprint: 98:61:f6:3c:2d:d5:0f:b9:6e:b2:a0:d3:be:e5:53:b7:7a:0c:26:3b
(R)eject, accept (t)emporarily or accept (p)ermanently? RA layer request failed: OPTIONS of 'https://svn.forgerock.org/openam/trunk': Server certificate verification failed: issuer is not trusted (https://svn.forgerock.org) at /Applications/SourceTree.app/Contents/Resources/git_local/libexec/git-core/git-svn line 2721

2 answers

1 accepted

This widget could not be displayed.

Hi Hiroyuki,

This seems like quite a common problem. The first thing I'd try is to try an svn command at the command line, then accept the certificate permanently. To do this you'll want to do the following at the command line:

svn info https://svn.forgerock.org/

It will then prompt you the "(R)eject, accept (t)emporarily or accept (p)ermanently?" that you've already seen, so enter 'p' and hit enter. After you've done this, then try in SourceTree again.

If the above does not work there's another option noted in this SO post whereby you can change the permissions recursively on ~/.subversion/auth. This is done by doing "chmod -R 777 ~/.subversion/auth". If this doesn't work then your last port of call will be to delete ~/.subversion/auth/svn.ssl.server and then you'll probably need to carry out the first step I mentioned so as to accept the re-issued certificate permanently.

It's basically because you need to re-issue the certificate. Hopefully that helps, if not, feel free to ask more questions.

Hello Kieran.

Thank you for your comment.

It works!!.

I executed svn info https://svn.forgerock.org/.

Thank again.

i tried svn info https://svn.forgerock.org but still i'm getting same error. Server SSL certificate verification failed: issuer is not trusted

This widget could not be displayed.

Kieran even fixed my connecting from XCode to an SVN server. Thanks!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

863 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you