Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,460,389
Community Members
 
Community Events
176
Community Groups

How to setup default push branch?

I have two remote brance, everytime I wanna push, I need to switch another branch in the push window. Can I set a remote branch as default?

2 answers

6 votes

Right-click your local branch in the sidebar on the left, then select Track Remote Branch, and then the remote branch you want it to track. That will then be the default when you push next time.

I did as what you said, the default pull branch changed, but default push branch didn't change.

In that case you probably need to change your settings in Tools > Options > Git, the 'Push branches' option should be set to 'upstream'.

I did what you said, the result is the same as before.

Hmm, that's a bug. 'Upstream' should pre-select that branch, I re-produced it here and will fix.

Was this ever fixed? I think I'm experiencing the same issue.

I'm still experiencing this issue as well...

I just needed to allow SourceTree permission to change my GIT configuration (global tab) and the problem goes away

I'm still seeing this issue. It has been over two years, when can we expect a fix?

Yes this is still an issue. In the right-click menu for the branch, the correct tracked remote is shown. If you click this menu item, the correct remote is pre-selected in the push branches dialogue. However, if you use the keyboard shortcut for push (command-shift-P in my case) when it opens the push branches dialogue, it pre-selects 'origin' even though the only branch ticked is one branch set to track a different remote. It feels like if you could skip the push dialogue (which I'd like to do as it's pointless anyway), it would work. Or if there was a keyboard shorcut for that right-click menu, it would also work as you could just hit enter to OK the push branches dialogue.

Deleted user Mar 15, 2017

Thank you, "Tools > Options > Git, the 'Push branches' option should be set to 'upstream'" helped me!

This bug still exists in Sourcetree 2.1, but you can work around it by renaming your preferred push branch to "origin", and then secret sourcetree magic will allow that branch to be the default push branch.

This bug still exists in 2020 version 3.2.1 (Mac), along with many other Sourcetree bugs. Sourcetree feels like abandonware.

Like Elalemanyo likes this

I am also having this issue. I set "pushe Branches" to Upstream on the settings, but if I use the push button on the top I need to check the branch where I want to push.
Why is not setting the current branch as default? I am missing something?
@ekloecker2 did you found a fix?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events