It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to prevent Sourcetree from switching back to Generic Account on optional extended integration.

I'm having a problem regarding a red exclamation point on the Remote Icon on the upper right part of Sourcetree, it the prevents push/pull functions.

The usual remedy for this is to stop using the generic account and choose my actual remote account instead. 

But the problem is that Sourcetree reverts to using the generic account after a few hours or so, causing me to do the fix again.

I'd like to find a way to resolve this issue.

Using version 3.3.4.3796

10 answers

it's insane the amount of annoying bugs they are introducing at every version, it's really bad right now a pain to use this.

Same problem exists in 3.3.8. Is Atlassian going to fix this bug?

Same problem.

Using version 3.3.4.3796

 

Co-Worker uses 3.2.6 -> no Problem

the best idea is to downgrade the app :\

Like Daniel_S_ likes this

Still happening today on 3.3.8. Really slows us down, this needs to be fixed asap.

Resolved by uninstall and install 3.2.6

Nicklim89 I'm New Here Apr 13, 2020

This worked for me

Like AdvAppSw likes this

I finally downgraded back to 3.2.6 again.  Thanks for the tip.

Same problem.

Using version 3.3.4.

Yes, this is really annoying.

Setting the default account in the "Tools > Options > Authentication" doesn't help.

Upgraded today from version 3.3.4 to version 3.3.8 (on Windows 10), the issue is still present.

Also the internal update checker (Tools > Options > Updates > Check For Updates) was not showing that there is a new version 3.3.8 available. Found the new version by visiting the Sourcetree website.

1 vote
Daniel_S_ I'm New Here Apr 29, 2020

As several persons have already suggested in this post I uninstalled Sourcetree 3.3.8 and installed 3.2.6 instead. Using Windows, don't know about other OS's.

Now I don't have that problem any longer.

Hopefully the people at SourceTree will fix this issue so I can upgrade to a current version again.

0 votes

Being new to Sourcetree, my first thought was,, that I made a mistake in the configuration. Sort of happy now to see, that it wasn't me but Sourcetree. I would even be happier when this gets fixed of course.

I've been fortunate to start using SourceTree for the first time on MacOS.
It worked pretty good: however the Windows-versions seem to be bug-infested, mediocre and unstable! Luckily there are better alternatives for Windows-OS (e.g. GitExtensions)
IMHO it seems that Atlassian is giving less attention to making a good Windows-tool and they really should be ashamed of wasting developer time with such an amateuristic tool.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,125 views 0 11
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you