It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to disable opening my home folder at startup?

Every time I start Sourcetree it opens a tab for my home folder. This tab requires 10 seconds to load (and my system disk is a SSD and everything is in the file cache!). 

 

During that time SourceTree is nearly unusable.

If I close the tab and restart SourceTree the home folder tab is there again.

 

How to I permanently disable this annoying home folder tab!?

 

BTW: Opening the home folder (not the document folder) is totally useless on Windows. 

 

4 answers

3 votes
Ana Retamal Atlassian Team Oct 27, 2017

Hi Jan Peter, is it possible that your Home directory became a repository by mistake?

To check this, go to your home directory and check if there's a ".git" folder (it will be hidden). You just need to delete the .git folder and Home shouldn't show up in Sourcetree anymore. 

Let us know if this fixed your issue!

Regards,

Ana

This solution worked for me, thanks.

Like Deleted user likes this

This is really important!

The fix is the following ,when you open sourcetree and the Desktop,Home,USERNAME or whatever is opened just click Exporer (Right upper corner) and delete .git folder ,which is hidden by the way.

This solution also fixes the UNREAL amount of RAM even if you close the repository!

No there is no .git folder in my home directory (all hidden and system files are shown). Only a .hg directory but that only contains the global "hgrc" file, "sourcetreeconfig" and "thgstatus".

Anyway from my perspective this looks like a hard-coded behavior as it is opened every time even if I close the tab before restarting Sourcetree.

 

Anyway I am not satisfied with Sourcetree. It often hangs, shows the waiting spinner or similar problems so that I have to kill the Sourcetree process. It looks like Sourcetree has severe problems with Windows 10 and/or .Net 4.7 or my system config.

 

Additionally it has problems with the git authentication (putty key) which works perfectly in command-line git as well as TortoiseGit. As I only need Sourcetree for Git this is a big problem (for HG TortoiseHg is way better than SourceTree - faster and easier to use). 

Same is happening to me, my first thought was maybe it was something I did accidentally. But there is no branch in SourceTree or any .git files in my documents folder. I assume it's hanging as it's trying to scan the entire documents folder which probably has lots of and large files (if it's like mine.) This feels like a bug TBH.

I just tried updating to the latest version, suddenly it doesn't happen. I assume this was a bug in an old version. The whole thing is still pretty sluggish though.

Same thing happens to me on Windows 7. No .git directory

Turns out there was, in fact, a .git directory in my user directory. Deleted it, problem solved.

hello guys.  

 

In your directory you need enable to show hidden files, so you delete the folder named ".git" and the git files(ex: .gitignore). When you start your git again this folder will be ignored. 

 

bye.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,962 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you