Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to I use SourceTree with Enterprise account

My Company has an Enterprise JIRA account that includes Bitbucket I do not see how to configure Source Tree to access it?

2 answers

0 votes
Ana Retamal Atlassian Team Jun 21, 2017

Hi Thomas! First you'll need to have your developers install SourceTree and register with their Atlassian account. After that, they can add the Bitbucket account. For more information they can read Get started with SourceTree.

Hope this helps,

Ana

Tried that and there is no provision to be able to log into our Enterprise account only the default ATlsasina account for a regular user.

Additionally, I attempted this just to get the tool set up and it appears your Windows Installer may be broken.

I can get into the personal account and can view my Fre License but the install goes no further.  I have attempted to uninstall and reinstall and still no luck with the installer.

 

Note: I use SourceTree on my home Personal PC running Windows 10. My employer uses Windows 8 on our Laptops and wondering of that's an issue? 

 

 

 

OK, the workaround was to create a totally new Atlassian Account just to complete the installation.  You should really fix this and or provide DETAIL instructions on how to accomplish this.

For a Company your size thinking about IPO and one of your product's documentation for the install is extremely poor and the support answers even worse.  Wasted several hours of time that I cannot get back.  Not very pleased with this at all. 

 

Ana Retamal Atlassian Team Jun 26, 2017

Hi Thomas, I'll pass your feedback to the team so we can improve the documentation. I tried following the steps to log in with an existing Atlassian account managed by Google and it worked for me, however it's confusing that when clicking the other option it's still asking for a license. 

Let us know if there's anything else we can do for you.

Best regards,

Ana

 

It's been a while since you answered this problem, but maybe things have changed in a newer version?

I have the same problem.
I have installed Sourcetree and logged on with my Atlassian account, but I cannot add any company account.
I cannot change the host URL for Bitbucket, and even if I login to our company Bitbucket the OAuth does not pick this up, and redirects me to the usual login, where I can't use mit company login.

Everybody else uses CLI, but I like Sourcetree, but maybe it's not for work accounts?

Best regards

Robert

... Forgot to mention - We have single signon to our Bitbucket Server, so everything works fine in the browser - Just not in Sourcetree.

/Robert

Facing the same issue... Not able to link SourceTree to my our Bitbucket

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

3,280 views 19 18
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you