Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How in SourceTree to get rid of a window “Git credential manager for Windows”?

After adding the repository, a window with the heading "git credential manager for windows" constantly pops up. Whatever I do (enter different logins and passwords, cancel), it then appears again. And in more than two copies. How to get rid of it?

I have registered the following settings in the .hgrc file, but this does not help.

[auth]
repo.prefix = http://to.my.repo
repo.username = <login>
repo.password = <pass>
repo.schemes = http

 29705609-8571ba22-8987-11e7-9ce0-9558efd48016

2 answers

0 votes
Gary Atlassian Team Aug 28, 2017

Hi Sukhrob,

Can you go to Control Panel -> Credential Manager -> Generic Credentials. Find any GIT, or HG entries, and remove them.  Then re add a repo - you should then again get the pop up window >> add the proper creds.  Can you confirm if you continue to get the popup after that?

Cheers,
Gary

There is no such menu item in the SourceTree program. I see such items as: File, Edit, View, Repository, Actions, Tools. Where can I find the "Control Panel"?

I'm fairly certain @Garyis referring to the Windows Control Panel -- if you are on Windows 10, searching for it via the Start Menu will get you there.

Capture1.PNG

I do not have "GIT, or HG entries" in the control panel (in the "Generic Credentials").

I do not have "GIT, or HG entries" in the control panel.

Gary Atlassian Team Aug 29, 2017

Hi Sukhrob,

It sounds like Windows is not saving your entry, which is why tou would continue to get the credential popup everytime you make a connection.

There are a few different solutions that have been successful listed at https://community.atlassian.com/t5/SourceTree-questions/Git-Credential-Manager-for-Windows-Popups/qaq-p/579905.

Cheers,
Gary

Like koobazaur likes this

It tries to connect to https://...
And I have explicitly set http://... in the settings (file .hgrc).
Is it talking about something?

Mike Corsaro Atlassian Team Aug 30, 2017

In your file you have "http" but it should probably be "https"

My repository is on http. By the https protocol it is not available.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

5,203 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you