Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,367
Community Members
 
Community Events
176
Community Groups

HomeBrew Git update always breaks SourceTree

SourceTree is a great product, but there's one thing that is really annoying. I have Git installed using HomeBrew. When I update Git (because of a brew update), the next time I start SourceTree, I get the following error:

Screen Shot 2017-06-06 at 3.50.13 PM.pngSourceTree suddenly has no clue where my System Git is installed. This problem is probably caused by the fact that Homebrew uses symbolic links in /usr/local/bin that point to Git versions in the Cellar folder. 

Now every time Git is updated (which is quite often), I have to click away a few error dialogs and go to Preferences and reselect my System Git location.

It would be great if SourceTree could be a bit smarter in handling HomeBrew Git installations.

Thank you.

3 answers

Please fix this bug, it should be pretty straightforward. 🙏

I've been using SourceTree and Homebrew for years. Every time I run `brew upgrade`, I see a ton of errors in SourceTree and this is very demotivating. Steps to mitigate the errors are time-consuming and pretty dull – I have to open SourceTree Preferences, go to 'git' tab, press 'Use System Git', press 'OK', press 'Use System git-lfs`, press 'OK', close preferences and finally hit cmd+R in every opened SourceTree window. Doing so is necessary every couple of weeks, with every new git update coming from Homebrew.

As a developer who's primary IDE is VSCode, I'm beginning to think of using it as my git client every time error modals in SourceTree are thrown in my face 😞

I figured out a manual but hopefully permanent fix.

If you manually edit the com.torusknot.SourceTreeNotMAS.plist file under ~/Library/Preferences/com.torusknot.SourceTreeNotMAS.plist.

set the gitCustomPath key to

/usr/local/bin/git

this will make it resolve properly on startup 

 

I believe the issue comes from the file selector and not something internal in sourcetree.

I've got this problem, too. In my opinion SourceTree should be able to follow the symlink from /usr/local/bin/git

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events