Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,026
Community Members
 
Community Events
165
Community Groups

Heroku error after update

I updated SourceTree and now the Terminal can not see Heroku.

I can see that Heroku works with cmd.exe but does not work with GitBash/MINGW32.

 

cmd vs terminal.png

1 answer

0 votes
minnsey Atlassian Team Aug 22, 2018

Hi

I don't use Heroku so apologies if this is stupid question.

You are trying to run a windows .cmd file in Git Bash. I wouldn't expect this to work, but I could be wrong. Has it ever worked? Did you previously use cmd rather than Git Bash as the terminal?

SourceTree opens GitBash and would run heroku cli commands until the most recent update. The cmd version fires the heroku file used by Git Bash, I presume.

It seems like the update has changed either a path or environment variable.

minnsey Atlassian Team Aug 28, 2018

Can you give me an example of the Heroku commands that would be run and what would trigger them?

Sourcetree doesn't know anything about Heroku so are these commands configured against Git?

Hi Michael,

I have opened an issue ticket with Heroku to assist as well.

The first basic test is to check the version of the installed heroku cli toolbelt, which fails.

heroku --version

This has always worked, but after I upgraded from Source Tree 1.9 to the new version, it failed. I rolled back to 1.9 but the damage seems to have been done already and I have done multiple re-installs of Heroku CLI and still no luck, thus me raising the issue here to see if anyone has faced a similar issue.

minnsey Atlassian Team Sep 03, 2018

Thanks for the additional information.

Sourcetree does make changes to the PATH when running Git/Hg commands but these are temporary and do not persist, certainly not between restarts or updates.

Is there any chance its due to a Git change?

From the Heroku logs, it looks like it tried to auto-updated the Heroku CLI and failed.

Not sure if that would make any path change. No Git Change seems to have occurred.

Not sure what to do next as I have been locked out from accessing Heroku at the moment. As mentioned earlier, I have been explaining the same issue to the Heroku support to see if they can assist, but no luck as of yet.

If anything comes to mind, let me know and will give it a try.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

61,833 views 127 27
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you