Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,191
Community Members
 
Community Events
176
Community Groups

Global Git Config is ignored after Windows update

Edited

Hello. After upgrading from Win10 1709 to 1909 my SourceTree installation neither honors nor can reach the global .gitconfig. Thus, when committing, SourceTree uses my Windows user name as well as associated e-mail address, which are both different from the configured name and address in .gitconfig.

Furthermore, even though the setting to allow SourceTree to edit the global .gitconfig is indeed checked, SourceTree does not modify the file when I change name or address in the settings. It looks like it completely ignores the file.

This occurs for both system and embedded binaries. However if I commit manually from the terminal, or if I uncheck "use global settings" in a repo, then the correct information is used.

How can I fix this behaviour?

EDIT: I of course uninstalled/cleared all AppData folders/reinstalled, to no avail.

1 answer

I moved the user config ([user], user.name, user.email) to the system gitconfig (in C:\Users\<user>\AppData\Local\Atlassian\SourceTree\git_local\etc) and now it works. Figures!

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events