Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

GitHub Repository not found, unable to clone repo

I keep running into problems where I'm unable to clone repositories from GitHub. It's always SSH key related, but I can't figure out how to fix it Previously, I've been able to fix it by running

 

ssh-add -l

or

 

ssh-add -K MY-KEY

with the key that is generated by SourceTree and added to GitHub. I've added all the keys this way and added them under Settings in GitHub.

 

In this latest case, I'm seeing the error "This is not a valid source path / URL" and saying "remote: Repository not found" in the log window. I'm able to clone the repo in both GitHub Desktop and Terminal, but SourceTree fails. I've deleted my SSH keys, regenerated and added them to GitHub, run those terminal commands, everything I can think of. I clearly have the proper access to the repo because I was able to commit through GitHub Desktop.

I'm admittedly not very adept at SSH keys, but I see no reason why this should be happening. Does anybody have any idea what might be happening here? This is very frustrating...

 

1 answer

OK, I should elaborate and say that I'm on a Mac and was actually able to fix this (somehow).

On the advice of some other threads, I went in the SourceTree preferences and under Git > Git Version, I selected "Use System Git" and selected the file named "git" under My HD > usr > bin. I hit "Open" and closed Preferences to assign SourceTree to use the system git (presumably).

I then went back into the Preferences and hit "Reset to Embedded Git" under Git > Git Version (next to "Use System Git"). I don't know why it fixed it, but it seems to have worked. I'm now able to clone the repo and have appropriate access rights.

Thanks @Jacob_Desch. This worked for me too.

Thank you!!

Worked for me too!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,332 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you