Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Git tag, status, log failed with code -1 "The system cannot find the file specified"

Just downloaded SourceTree and dragged my project folder into the window. When I click into it all I get is a series of errors saying:

 

'git status' failed

'git log' failed

'git tag' failed

 

As below. What am I doing wrong here?

 

 

git-error.jpg

1 answer

1 accepted

0 votes
Answer accepted
Mike Corsaro Atlassian Team Apr 17, 2019

It looks like git isn't able to access the files in the repository -- do you have anti-virus or anything like that installed that's known to cause issues with programs attempting to access your filesystem?

Hmm, I have Norton antivirus. But turning that off doesn't seem to make any difference...

 I frequently use git through the command line? And if I hit the terminal button from within sourcetree I'm able to use it through that interface... is there something specific about git through the GUI that I need to be aware of?

Mike Corsaro Atlassian Team Apr 17, 2019

`C:\wamp\www\palsagency` is the path of the repository, right?

 

It's possible that git is on the "approved applications" list, but Sourcetree isn't so when git is run from it your AV might get confused.

 

I assume you're using the latest version of Sourcetree? Could you tell me the current version of git and if you're using embedded git or not (check under Tools > Options > Git > Git Version)?

Thanks for this, having done a bit more digging and based on this answer I tried switching to the embedded version of Git and it worked.

But by the looks of things it was looking for system git.exe under c:/Program Files(x86)/Git/cmd/ when in fact no such file exists on my machine. The git.exe is in c:/Program Files(x86)/Git/cmd/bin

Source Tree Version: 3.1.2

Git --version git 1.7.9.msysgit.0 (perhaps this is way out of date?)

So:

Is there any drawback to using the embedded Git version when I do have another version of Git installed on my machine?

Mike Corsaro Atlassian Team Apr 23, 2019

Ah, yeah that's a very old version of Git (the latest version is 2.21.0).

 

Using embedded git shouldn't cause any problems -- we include that as a feature for this exact reason 😊

Like Grimmrobe likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,336 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you