Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Git Credential Manager for Windows keeps popuping up Edited

I know that this issue has been raised in te past and I went over all of the posts and "answers".

I tried editing gits config, system and global. I tried all sorts of passwords and usernames. Sometimes this annoying popup goes away for 10 minutes, sometimes days and sometimes it comes up every couple of seconds. 

Please, Atlassian Team, could you please guide me on how to analyse this issue? How can I know what am I doing that is wrong? How can I know what repository is causing this? How can I know what username it expects? 

Please help me, this is super annoying and affects our team's productivity.

1 answer

1 accepted

1 vote
Answer accepted
minnsey Atlassian Team Jul 26, 2017

Hi SoureTree for windows now shares credentials with Git via the Git Credential Manager or GCM.

The credentials for both are stored in the Windows Vault or Credentials Manger, the entries are prefixed with 'git:'

To determine what is going on I would

1) remove all existing 'git:' prefixed entries from the Windows Vault.
2) remove any credentials from git config files.
3) disable the automatic remote checking of repositories in SourceTree

Then restart SourceTree and open each repository in turn and do a fetch. This should trigger the GCM to request credentials. Entering them there shoudl mean they are stored correctly.

There have been issues with the GCM previously with HTTP rather than HTTPS URLs, if possible use HTTPS.

Also is using Bitbucket try and ensure you are using URLs that contain the username, e.g. https://username@bitbucket.org/repo-owner/reponame.git

The GCM can only store 1 set of credentials fro GitHub and hosts other than bitbucket. If you use multilpe accounts to access GitHub or another host the GCM will reprompt each time it changes account.

Hi,

Number 3 seemed to do the trick.

Thank you very much!!

For others who have this issue, here is how you do it in SourceTree 2.1.2.5

1. Goto tools -> options 

2. Uncheck "Check default remotes for updates evey [10] minutes"

 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

5,012 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you