Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,299,231
Community Members
 
Community Events
165
Community Groups

Getting error - Failed to check login for user - when registering SourceTree

I just installed SourceTree 3.1.3 and I am unable to register the application to use it. I copied the URL exactly as it displayed on the bitbucket website and entered my password (same one that allows me to access my account on the bitbucket website, but I am getting a Failedto check login for user.

 

On the registration page I enter:

https://<my username>@bitbucket.org/<My team name>/<my repo name>

Then I enter the my username and am prompted for the password. I get them error. When I review the SourceTree log It displays the following and that it can't be found:

https://<my username>@<my username>@bitbucket.org/<My team name>/<my repo name>

I tried removing the <my username>@ from the URL and get the same results, but the log message displays the URL correctly after it appends the username to the URL. Any assistance would be appreciated.

 

Thanks! Don

 

5 answers

In our case we had to install certificates

I am in the same case. I can configure any other Tool for git except the source tree. I am getting the same issue: faild to check login for: ......

I am having this problem but I have no idea how to fix it can anybody help me??

Is there an update to this issue? Thanks!

0 votes

Hello Don and welcome to the Community!

We appreciate you including details into what you’ve attempted already and the errors you’re seeing in response. When you’re attempting to connect to Bitbucket, could you please use the following URL:

Use your standard Bitbucket account credentials to authenticate.

Please let us know if you’re still having issues registering your account with Sourcetree after attempting the above.

Regards,
Stephen Sifers

Thank you for the quick reply Stephen. I am getting the same error.

Thanks!

Like Stephen Sifers likes this

Hello Don,

Thanks for confirming. To ensure we're trying to authenticate to the right place, you do use Bitbucket cloud correct?

Could you please include a screenshot of the error as well? I can use this to pass it along to the Sourcetree team so we investigate further. (Please remove or blur any sensitive information before posting).

Regards,
Stephen Sifers

Here is the result of me trying to log in. a screen shot of the log file (with my username removed) is below. Thanks!Screenshot - 9_12_2019 , 5_38_33 PM.png

Screenshot - 9_12_2019 , 5_42_26 PM.png

Hello Don,

I reviewed your account and I am unable to find any referenced or linked instances of Bitbucket cloud sites. Can you please confirm you have a Bitbucket account that uses the same email as your account for Community?

If not, please let me know the Bitbucket instance you're using so we see why you're being reported as not having an account on Bitbucket.

Regards,
Stephen Sifers

Apologies for wasting your time. My coworker and I figured out the issue. I was selecting BitBucket Server and it should have been BitBucket when configuring SourceTree. I have it all set. Thank you!

Like Stephen Sifers likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

62,258 views 127 27
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you