Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Frustrated with credential while code commit Edited

I had already contacted SourceTree Support Team for this issue. Removed the stored passwords in the KeyChain. It worked fine for some time. I had to reset the BitBucket account password. After resetting the password for BitBucket, when I logged into SourceTree with the new password, then tried to commit new website code, I started getting this issue again. Why does it keep asking me Password if I have signed into my BitBucket Account? This is very annoying and frustrating 

 -----------------------------------------------------------------------------

git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree commit -q -F /var/folders/5d/7r4vxql17q1_d5d3t4zqjl_40000gn/T/SourceTreeTemp.Evdjyy

 

 

git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree push -v --set-upstream origin refs/heads/master:refs/heads/master

Pushing to ***************

2018-03-22 12:49:46.809 git-credential-sourcetree[3630:502525] Error generating password due to missing uuid. Please report this to Atlassian.

2018-03-22 12:49:46.812 git-credential-sourcetree[3630:502530] Something went wrong. one or more parameters required to renew token is nil.

remote: Invalid username or password. If you log in via a third party service you must ensure you have an account password set in your account profile.

fatal: Authentication failed for '*********************************.git/'

Completed with errors, see above

1 answer

0 votes
Manju Atlassian Team Mar 23, 2018

Please remove the account and add it once. That should resolve the issue you are seeing. This can happen when a old token was not updated or removed when you added the new credentials. We are actively working to get this resolved in an upcoming release. 

Apologies for the inconvenience and thanks for your patience. 

 

Thanks,
Manjunath
Sourcetree Mac Developer

Screen Shot 2018-03-23 at 11.10.43 AM.pngIt is so frustrating. It just keeps displaying even when I have removed the account and trying to add. And all the time when I am working, even if I am on some other window, it just pops up

And I did remove and add the account before posting the issue..Frustration is not just the popup but the whole signin process. GitHub was so easy

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,292 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you