Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Finish Feature with GitFlow not finishing feature. Edited

Hello,

I am using SourceTree v 2.6.10.0 and Finish feature in gitflow hangs forever with this in output window:

sh.exe "C:\Program Files\Git\usr\bin\git-flow" feature finish -k TEST_v2018-34
fatal: HttpRequestException encountered.
   Ett fel uppstod n�r beg�ran skickades.

System git 2.18.0

Any suggestions?

Thank you :)

5 answers

1 accepted

12 votes
Answer accepted
minnsey Atlassian Team Sep 11, 2018

Hi 

I believe the problem is due to the a buggy version of the Git Credential Manager for Windows, GCMW, that ships with Git for Windows. v1.17.1 fixes this https://github.com/Microsoft/Git-Credential-Manager-for-Windows/releases/tag/v1.17.1

Sourcetree attempts to bypass broken versions of the GCM in favour of a fixed version it bundles, but it cannot tell git-flow, or other extensions like git-lfs, to do this, they will revert back to the default broken version bundled with Git for Windows.

Workaround

Deleted user Feb 06, 2019

You saved my day!

And you also saved MY day! Thank you minnsey.

FWIW, I ran into a very similar problem today using the Embedded Git v2.17.1 & no known hooks installed.  I thought I may be behind on my Git version, so attempted to update the Embedded version ... this ended in an error message on every attempt, so I checked my task manager and found some zombie Git processes hanging around.  After killing them, and closing all running apps, the embedded Git finally updated, but this did not fix the original problem.

I had to login to my remote Git account (bitbucket) and manually merge my feature branch with "develop", then delete the feature branch.  As you can imagine, my local get repo was very confused when I restarted SourceTree.  Eventually SourceTree did get back in sync ... I think I had to first Pull "develop", then manually delete the now bogus feature branch.

After all that, I was able to Git-flow create a new feature and move forward with work, although i haven't tried to "finish" that new feature branch yet.  The problem may persist.

Got the exact same issue, only for finish feature and follow your advises when I found lots of Git tasks. Even after killing all of them and rebooting I still got:

sh.exe C:\Users\xxxxx\AppData\Local\Atlassian\SourceTree\git_local\usr\bin\git-flow feature finish xxxxx
fatal: HttpRequestException encountered.
An error occurred while sending the request.

But I don't have any problem with pull/push, pretty weird. Watching this thread in case one day got any solution.

Just this morning I got the error to go away by creating new SSH Keys in SourceTree and then associating the public key with my bitbucket account.  I think that maybe something happened to my old key?  ...but that wouldn't explain why other git features work flawlessly. 

I dunno.  Give it a try to see if it works.

0 votes
minnsey Atlassian Team Aug 28, 2018

Hi

That looks like a web request error. AFAIK Git-flow does not make any web requests during its processing, do you have any git hooks installed?

For info I got this issue with both embedded and system GIT. I have no issue when pushing or pulling, this only occurs when doing Git flwo > Finish feature:

sh.exe C:\Users\xxxxx\AppData\Local\Atlassian\SourceTree\git_local\usr\bin\git-flow feature finish xxxxx
fatal: HttpRequestException encountered.
An error occurred while sending the request.

That may help identify the root cause.

I just looked at what happened during PUSH and found this:

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks -c credential.helper= -c credential.helper="C:/Users/xxxxx/AppData/Local/ATLASS~1/SOURCE~1/GIT_EX~1/GIT-CR~1.EXE" push -v --tags origin develop:develop
fatal: HttpRequestException encountered.
An error occurred while sending the request.

POST git-receive-pack (202 bytes)
remote:
remote: Create pull request for develop:
remote: https://bitbucket.org/xxxxx/rapid4cloud-platform/pull-requests/new?source=develop&t=1
remote:


Pushing to https://xxxxx@bitbucket.org/xxxxxx/xxxxxx.git
To https://bitbucket.org/xxxxx/xxxxx.git

So it seems issue is also during other command but somehow PUSH is trying another way (POST) and it is working. But not feature finish.

Well, I've tried to remove Sourcetree and all temp files.

Removed my creds in the gui.

Still getting that problem, but merging manually works fine (sourcetree is no happy about that).

Current solution is to ask someone else to checkout that feature and finish it.

Seems to be working in older versions without problems.

I have the exact issue.  With the newly installed Git for Windows, I thought everything was resolved.  But seems like most of it, while leaving the "Finish Feature" still having this problem.

minnsey Atlassian Team Oct 22, 2018

There appears to be an issue with the Git Credential Manager 1.18.x bundled with Git 2.19.1

Hahahaha indeed I'm using that combination.  Looks like this pair of applications hate each other.

I am also facing issue in Finish Feature.

Getting error like:

sh.exe C:\Users\Lenovo\AppData\Local\Atlassian\SourceTree\git_local\usr\bin\git-flow feature finish splsh_screen
fatal: HttpRequestException encountered.
An error occurred while sending the request.

it is running forever.

Other features like, merge, create new are fine.

Please suggest.

minnsey Atlassian Team Jan 25, 2019

I think it is very likely that it is due to authentication issues. Please try upgrading your Git , and Git Credential Manager which is bundled with Git for Windows, to 2.20.1 or higher

Like aleksey-bykov likes this

I am having this issue on mac version 3.12 (216)

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

2,916 views 4 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you