It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

File list suddenly disappeared from log view for all repos

All of a sudden the log view in SourceTree no longer lists the files that were changed in each revision. This is happening on all repos (I have a couple dozen) and in all revisions. It just started after my last commit (which worked fine; I confirmed with the Hg command line tools).

Restarting the app didn't help, so I restarted my entire machine (MacBook Air 2012, OS X 10.8.4), which also didn't help. This has never happened before, but now I can't seem to fix it. I've verified that all my actual repos are fine, so it's definitely just a bug in SourceTree.

Pretty huge bug, though, as it makes the app pretty much completely unusable.

Couldn't find anything on Google or in a search here.

8 answers

1 accepted

3 votes
Answer accepted

I was able to resolve this by deleting all of SourceTree's cache, saved state, preferences, and Application Support files (except the license file). Obviously something got hosed in there (probably the App Support or preferences).

We recently issued an update so you can't hide the file list. This is what must've happened in your case before the lastest version of SourceTree. Sorry about that! Going forwards it shouldn't happen again.

Hi @Kieran Senior [Atlassian], Another customer reported that they encountered the same problem. They are using SourceTree for Mac v2.0.5. They could not resolved it just by reinstalling the app. They resolved it by Wiping SourceTree Preferences as instructed in this page - https://confluence.atlassian.com/display/SOURCETREEKB/Wiping+SourceTree+Preferences

Just happened to me. Only "defaults delete com.torusknot.SourceTreeNotMAS" fixed it, though I tried the other steps (update from 2.0.2 to 2.0.5_2, cd ~/Library/Application Support/SourceTree; rm -rf *), first.

Just happened to me again, only needed "defaults delete com.torusknot.SourceTreeNotMAS" to fix it.

Just happened again, updating from 2.0.5_2 to 2.0.5_3 did not fix it, `defaults delete com.torusknot.SourceTreeNotMAS` did fix it again.

This still happened to me as well. As Peter noted, I only needed 'defaults delete com.torusknot.SourceTreeNotMAS' to fix it.

I can also confirm it's still an issue. The pane is there however, and can be dragged if you place the mouse cursor carefully next to the sidebar

Can confirm this on Mac version 2.0.4. Easier than clearing all the data. Thank you!

Solved this by staging a file with the ellipses icon in the big diff view. That popped open the file list which I could then expand again.

Just wanted to bump this thread, as this is still an issue in version 2.0.5.2 - I had an older version of SourceTree, and upgrading does not fix the problem. (Though Kelvin's solution did solve the problem, sort of? I was somehow able to drag out the file list after doing that)

I had the same thing also under 2.0.5.2

Addendum: the first changed file is still shown in the diff pane. It's just that the file listing itself is gone, so I have no way to see what files changed or view the diffs for any other ones besides the first.

Addendum: the first changed file is still shown in the diff pane. It's just that the file listing itself is gone, so I have no way to see what files changed or view the diffs for any other ones besides the first.

This just happened to me with version 2.0.2 of SourceTree.

This is STILL happening to me about once a week in the latest version of SourceTree (v2.4.1, Oct 20th 2017).  In the History View, the 'files changed' pane disappears.

The problem seems to be that it minimizes itself.  The solution is to drag it back outwards.  The issue with that is that SourceTree thinks you're trying to drag the branches list instead.  There is literally a ONE PIXEL WIDE area, just to the right of the branches list, that you can grab to enlarge it.  It usually takes me about 5-10 tries to get it.

Screen Shot 2017-10-20 at 3.02.18 PM.png

Thanks this was driving me nuts. It is pretty crazy that you have to pull a divider that can't be seen to re-show the file list view. I am on 4.0.2 which is the latest. 2013 to 2020 this issue is still a gotcha. Interesting. It is like a ninja test to see if you can fix the tool you need!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,917 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you