It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Failed connect to BitBucket.org:443

Hi,

I am attempting to use SourceTree to clone a valid shared repository in Bitbucket. After entering the source/path for the repo into the Clone Reporitory screen, i receive an error message "This is not a valid source path / URL". Selecting the details button shows the error message "fatal: unable to access 'https://cybersmartwebteam@bitbucket.org/cybersmart/cybersmart.git/': Failed connect to bitbucket.org:443; No error"

Error Details

We are sitting behind a proxy, but the proxy setting have been set up correctly inside SouceTree because we can see the repository name appear when we select the globe icon to the right of the "source path / url" field.

Screengrab - Hosted Repositories

Can someone please let me know why this setting is not going through the proxy and help me with this setup??

Thanks

Stephen

4 answers

Tools->options->Network tab, verify your settingsNetworksettings.png

 

Worked a treat, thank you very much for your help :-)

Signed up just to say thank you for this suggestion. It was the "Add proxy server configuration to Git / Mercurial" checkbox that I hadn't done. After that, things started working.

Like # people like this

Worked like a charm ! Thank you sir, you saved my day.

It worked perfectly. Thank you.

awesome working ! thanks brother

OMG! such a simple solution and hours of desperation! thank you

That worked with a different port. Thank you very much. You saved me. :)

Really the solution suggested worked for me after several attempts for solving the issue. Thankyou:)

Sorry...Where to find this Tools->options->Network tab, verify your settingsNetworksettings.png

Same question... where is Tools->options->Network tab, verify your settingsNetworksettings.png?

Like fandy kurniawan likes this

Thanks a ton..it worked finally

For Ubuntu 14.04

I had the same issue in ubuntu.

But after removing 104.192.143.2 bitbucket.org from etc/host file.

Its started working for me.

This fixed it!

I had added this line to my hosts file months ago to fix a similar SourceTree issue and totally forgot 😂

Like Ankit Sharma likes this

This did it for me, after wasting days on the Net. Thank you :)

worked for me thanks

I had the same issue

Same issue in my Ubuntu 14.04

0 votes

I'm having the same issue but cloning directly from terminal on MAC. Where can I find this Tools > Options > Network tab?

Thanks a lot

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

2,037 views 0 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you