It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Error when trying to push commits from Sourcetree to Bitbucket

I am trying to push change I have made in my repository to Bitbucket. I am using Sourcetree for this. I am using HTTPS.

I am getting a timeout error. "Failed to connect to bitbucket.org port 443: Timed out"

This worked fine when I did my initial commit and a few afterwards. 

If I copy the URL into my browser I get a bitbucket 404 that says "That link has no power here."

Can someone please help point me in the right direction of what is going wrong?

Thanks :)

1 answer

1 accepted

1 vote
Answer accepted

HI @Jacqui Lewis

Welcome to the community!

It should be the Local network firewall or DNS issue, please look at the below articles.

https://bitbucket.org/site/master/issues/12184/failed-to-connect-to-bitbucketorg-port-443

https://bitbucket.org/site/master/issues/15411/failed-to-connect-to-bitbucketorg-port-443

Hoe it helps.

Thanks @Yogesh Mude I have tried the recommended commands in the first issue and both the ping and the trace route are fine. 

HI @Jacqui Lewis

bitbucket 404 that says "That link has no power here."

Can you please confirm if you are able to access the repo from bitbucket with appropriate permission.

Yes I created this repo.

ok, using Sourcetree you are not able to push the change to remote repo correct?

Can you please try to clone the repo and do the changes to working dir and then using git try to push the changes to the remote repo.

Correct. I do not know the correct commands using git which is why I am using Sourcetree. At this stage the only working directory I have is the one that is no longer working.

Follow the below steps to clone the repo using git.

1. Open the git bash on your system.

2. Create the directory in which you want to clone the repo and redirect the cursor into the dir

3. Configure your username and email.

> git config --global user.name "XXXXX"

> git config --global user.email "XXXX@abc.com"

4. Initialize the git

> git init

5. Copy the repo URL from bitbucket and clone it to Working dir.

> git clone <Repo_URL>

6. Change any file within the working dir and then push the changed to remote rep.

> git status

> git commit -a -m <commit_massage>

> git push -u origin <Branch_name>

Thanks! How do I redirect the cursor into the dir?

To create dir.

> mkdir Test_repo

Go to the newly created dir and then clone the repo in this.

> cd Test_repo

@Yogesh Mude I got to step 5 and I got the same error

"it/': Failed to connect to bitbucket.org port 443: Timed out"

ahh..then there will be a network/firewall/DNS issue please check with your IT/Network team.

is there anything specific they should can check?

Thank you @Yogesh Mude

I added a proxy into Sourcetree rather than using the default windows proxy and this seems to have fixed the problem.

Thanks again for your help!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,970 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you