Error when opening git bash terminal

When I click the "Terminal" button in SourceTree, this funky error message pops up:

"It has not been possible to start the Git Bash Terminal."

screenshot1.png

This is on Windows 8 with SourceTree v1.6.23.0. Does anyone have a clue how to fix this? I've tried using embedded and system version of Git with no luck at all. Thanks!

Edit: Good advice below. It appears this started in 1.6.23.0 since 1.6.22.0 works for me. For anyone else reading having this issue, just change the number in the download link on the main download page from 23 to 22 and that will workaround this issue in the meantime until they fix it. Direct link here

3 answers

I have the same problem on Windows 7 after updating to version 1.6.23 yesterday. It worked fine on all previous versions. For now, I'll go back to version 1.6.22 and wait for a fix.

Same problem here on Windows 10. Downgrade also worked.

Try this suggested solution: http://stackoverflow.com/questions/33790602/sourcetree-cant-open-git-bash Haven't come across the explanation as to why a git upgrade is necessary

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

791 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you