It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Error generating password due to missing uuid

Hi!

I'm on a Macbook running 10.13.1 High Sierra and newest Source Tree Version 2.7.

 

For a couple of weeks (on an older Source tree version) it suddenly started to ask me for my password twice every time I wanted to pull or push. At some point I couldn't stand it anymore and I decided to update SourceTree in the hope it would fix it.

 

Now that I updated nothing works anymore, I can't pull or push. I saw lots of people experiencing the same issue even 2-3 years ago. I tried re-installing, or clearing the cache but nothing seems to fix it. 

This is the error message i get now:

git-credential-sourcetree[30381:15121586] Error generating password due to missing uuid. Please report this to Atlassian.

 

What can I do ?

Thanks..

1 answer

0 votes
Manju Atlassian Team Jan 31, 2018

I recommend you to clean re install (including removing Sourcetree's app support folder at ~/Library/Application Support/SourceTree and removing old keychain items written by Sourcetree). You will end up loosing your setting (bookmarks). But, that should get everything else working. 

Make sure you add the account in preference and use the same protocol as the remote URL fo the repo cloned (ssh/https). 

Thanks!

Hey Thanks!
Well I already lost my bookmarks and I tried to do a clean reinstall. But the weird thing is, there is no such folder. Application Support/SourceTree does not exist.

Manju Atlassian Team Jan 31, 2018

Never heard that!!

You should also remove 'com.torusknot.SourceTreeNotMAS.plist' at ~/Library/Preferences/

Hope that works at least. 

I managed to get the UUID issue fixed, by clearing the keychain entries! Thanks, but now I get a "remote: Repository not found." I had this issue too before I updated to the newer version.

Manju Atlassian Team Jan 31, 2018

Alright! One step at a time. Can you describe the steps when you see this new error and include what type of repository, host, account configuration and remote URL protocol for the repo you are using?

Github, Https, OAuth. I see the error when I try to pull from the remote. 

Oh no... but when I try to push it says:

Error generating password due to missing uuid. Please report this to Atlassian.

remote: Repository not found.

 

Before I got this error, when I tried to push, it actually gave me the normal error that there is changes on the remote and I need to pull first, so it's definitely hooked up with the remote

Manju Atlassian Team Jan 31, 2018

I am assuming you have added the GitHub account in Preferences. Can you please check keychain if Sourcetree has successfully saved your tokens. You should be able to find two items in keychain and this time, one file in Applications Support folder with the name <username>@STAuth-github.com. If possible, please attach screenshots to help me get a hold of the situation. 

Thanks!

I just tried to change to basic but no luck. I get this error:

 

2018-01-31 23:34:24.085 git-credential-sourcetree[31641:15415041] Error generating password due to missing uuid. Please report this to Atlassian.

 

Also there is nothing in the keychain for github.Screen Shot 2018-01-31 at 23.33.54.png

Manju Atlassian Team Jan 31, 2018

Can you run this on terminal and paste the output here?

defaults read com.torusknot.SourceTreeNotMAS.plist anonymousUUID

Manju Atlassian Team Jan 31, 2018

Also, is this only with GitHub? Or you see these kind of errors with Bitbucket also?

1C3C6B2B-9FEB-4CBC-9195-24D7F1B95C93

 

Yes, it works fine with bitbucket. Bitbucket also has a keychain entry, and github does not...

Manju Atlassian Team Jan 31, 2018

Thanks so much for the feedback. I will submit a ticket for this to investigate the issue and would get back to you with a debug build with extra logging to identify and resolve the issue. 

In the meanwhile, I would recommend you to use SSH for GitHub and generate a new key with Sourcetree if you don't have any. We'd upload this to GitHub once you save the account, so you don't need to do anything extra. Also, in the repository browser, right click on the repository and click on Convert to SSH so that you can use it with the new account setup. 

Hope this workaround gets you up and running!

Manju Atlassian Team Feb 02, 2018

Hey @Patric Corletto

Can you try this build and give me all the logs that you get?

https://drive.google.com/file/d/1qM8VRBtr-m_d0lge8Nfs1RtTtBG62JBo/view?usp=sharing

This would help us identify and resolve the issue.

Appreciate your help on this.

 

Thanks!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,895 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you