Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Error Code 128 shows unknown network drive

Ben Ruming March 31, 2014

I have been happily using SourceTree for 4 months, when suddenly none my local repositories would be displayed in the tool.

The errror says 'git status' failed with code 128: unable to access 'H:\/.config/git/config': invalid argument... then it shows the correct local path to the repository.

I have made no changes to the config, nor performed any updates when this issue hit.

I have tried updating the embedded GIT and using it, without success. I have also tried re-installing without success.

Using git status and other commands from the SourceTree termainal works fine

Any ideas?

4 answers

2 votes
Pawel Cioch April 29, 2019

This error is relevant to the fact many companies map network drive and put your user data directory in such a drive, in my case it's mixed, most software uses regular home directory, but for some reason ST binds to this mapped one, and global config is being placed there and if you work from home without VPN sourcetree will complain missing that location.

Here is an example from my own investigation  https://stackoverflow.com/a/55839051/1818723

Look how I'm mapped to \\it-nap-data\...

Now when at home I have exactly same error as you are but this is a bug in SourceTree, because git command line reads my %UserProfile%

Something is 100% wrong with SourceTree on windows. It should read only %UserProfile% variable. Still there is a chance your company mapped %UserProfile% to network drive, but in general when you work remotely you need to have apps locally so under most cases it's SourceTree fault 

Seth
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
April 29, 2019

That's great debugging! Clearly you've demonstrated a use case that the SourceTree devs never considered/tested. Have you reported a bug?

https://jira.atlassian.com/secure/Dashboard.jspa

Pawel Cioch April 29, 2019

No I haven't reported a bug, I don't know how to describe it :) I just hacked my company laptop to not use this network drive in the registry

HKEY_CURRENT_USER\Volatile Environment

but since this is Volatile Environment it may not work after restart, the other thing I created same global config in both locations in

%UserProfile%\.gitconfig

and in

%UserProfile%\AppData\Local\Atlassian\SourceTree\git_local\mingw32\etc\gitconfig

if registry to be updated after restart/domain re-login I may try to hack it even more.

Finally I don't report a bug because many people did about [includeIf] any Atlassian indicated ignorance, so why would we bother to try to fix a product that "works" for them  

1 vote
joelkdennis
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 12, 2014

I have run into the same exact problem.  My H drive is a network drive which is used to map the "home" drive on my company's network.  Whenever I lose access to the H drive, I receive the error in git.  Sometimes, the H drive will lose connection at work due to network issues. If I am at home at not connected to my work network via vpn I will get the issue.  As soon as I connect to the VPN, the issue goes away.  It appears that my local GIT has installed some reference to my H drive which I never use.  But since it is mapped as the home drive, sourcetree, which is using git, is now dependent upon my H drive.  I haven't made the change yet to fix it, but I believe I may have to change the default home drive, then reinstall git.

0 votes
Pawel Cioch May 31, 2019

Can Atlassian fix this bug and using  HKEY_CURRENT_USER\Volatile Environment\HOMEDRIVE as this is mapped to network share at enterprise. Just read global .gitconfig from %UserProfile% 

0 votes
Seth
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 31, 2014

There are many practical problems with using a DVCS (git/mercurial) to manage pseudo-local repositories (such as network storage). This is a Git issue, not a SourceTree one. This post has a similar issue and links to even more questions.

I STRONGLY recommend having your repository actually be local, and add this network location where you also want your files to live as a remote that you can push to.

Feel free to explain any reasons why that doesn't work for your particular situation.

Ben Ruming April 1, 2014

Hi Seth,

All my local repositories are stored in my C Drive. My remote repositories are located on a server in my regional data centre. I have never stored anything on the H drive SourceTree is indicating, so not sure why it suddenly started referencing this drive. As mentioned, the error shows the correct local file system's location of my repository... very odd.

Seth
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
April 1, 2014

Ah, that is very odd. Do you have an H drive? Is it a network drive or something else?

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events