It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Error : Askpass.exe: No such file or directory

Reza Seedin Oct 04, 2018

Hi All,

After updating sourcetree I seem to be getting this error

git -c diff.mnemonicprefix=false -c core.quotepath=false fetch origin
fatal: HttpRequestException encountered.
An error occurred while sending the request.

error: cannot spawn C:\Users\Reza Seedin\AppData\Local\SourceTree\app-3.0.5\tools\Askpass.exe: No such file or directory
bash: /dev/tty: No such device or address
error: failed to execute prompt script (exit code 1)
fatal: could not read Username for 'https://github.com': No error

Completed with errors, see above.

 

I have tried to re-adding my username password as well. Any thoughts?

9 answers

1 accepted

4 votes
Answer accepted
Michael Minns Atlassian Team Nov 07, 2018

An update to the GCM has been released https://github.com/Microsoft/Git-Credential-Manager-for-Windows/releases/tag/1.18.3

This should improve the situation significantly and we'd recommend upgrading.

Reza Seedin Nov 07, 2018

Hi Michael, Does this come automatically with Source tree (version 3.0.8?) or do we need to update this separately as per your link above. I have have fallen back to 2.6.10 

Michael Minns Atlassian Team Nov 08, 2018

It is not in 3.0.8.

Deepening on how quickly it gets bundled into a Git release it will get put into a future Sourcetree release.

Like Reza Seedin likes this
Mark Graves Nov 08, 2018

Windows Credential Manager:  1.18.3

SourceTree:  3.0.8

Git:  2.19.1

EVERYTHING WORKS NOW!!

Like Reza Seedin likes this
Reza Seedin Nov 08, 2018

Hi @Michael Minns,

Can confirm that after the update to the GMC manually https://github.com/Microsoft/Git-Credential-Manager-for-Windows/releases/tag/1.18.3 this work fine with SourceTree:  3.0.8 with embedded GIT for me.

Thanks all and thanks to the team at Sourcetree. Keep up the good work

Reza

Tommaso Vietina Nov 12, 2018

Thank you. Now it works.

14 votes
Thilo Enters Oct 11, 2018

Had the same issue today, the following workaround helped:

  1. Go to an old installation of SourceTree, for me it was here:
    C:\Users\<username>\AppData\Local\SourceTree\app-2.6.10\tools
  2. Select the following files and copy them
    Askpass.exe
    Askpass.UI.Wpf.dll
    SourceTreeShared.dll
  3. Paste the files you copied in the following directory:
    C:\Users\<username>\AppData\Local\SourceTree\app-3.0.6\tools
Joseph Gershgorin Oct 14, 2018

This work-around worked for me. I have two connections setup VSTS and a Githhub account. VSTS worked fine and Github worked fine when accessing repositories I created, but when trying to access a private repository I have contributor access to the above work-around was needed. 

Bartosz Piec Oct 19, 2018 • edited

This workaround works but still outputs an error:

fatal: ArgumentException encountered.

   An item with the same key has already been added.

 

2 votes
Michael Minns Atlassian Team Oct 08, 2018

Hi

Firstly thanks for flagging this up, it does look like a bug that we will look into.

However Askpass.exe should only be used if the Git Credential Manager, GCM, has failed to retrieve credentials, either from storage or by prompting you the user.

I think that is why we missed this bug because we never hit that state.

Were you prompted at all with a Graphical UI for your GH credentials?

If you haven't already can you try installing  Git 2.19.1 as this contains the latest GCM version and then switch Sourcetree to use it as a System Git in the Tools/Options/Git tab

Adrian Tompkins Oct 08, 2018

I had the same problem. No prompt. Git already 2.19.1.

I have rolled back.

Simon Thomé Oct 09, 2018 • edited

Hi,

I also have a similar problem. I updated Sourcetree to 3.0.6 and simultaneously changed our repositories to use SSL. I am using System Git 2.19.1, I get the following error:

fatal: ArgumentException encountered.

   An item with the same key has already been added.

 error: cannot spawn C:\Users\simon.thome\AppData\Local\Sourcetree\app-3.0.6\tools\Askpass.exe: No error

 

Switching to embedded Git 2.18.0 seems to fix it for now.

Maxim Beliy Oct 10, 2018

Neither embedded 2.18.0 nor system 2.19.1 worked. Still no prompt and error "No error".

Uninstalling sourcetree 3.0.6 and installing latest from sourcetree site (2.6.10!) helped.

Steve Esson Oct 11, 2018

Same as Maxim, steer clear of v3!

Reza Seedin Oct 14, 2018

I was not prompted, I have reverted back to 2.6.10. Embedded git worked for my oragansations GIthub but I am a contributed to one of my clients which still did not work.

Reverted and now up and running.

2 votes
Mark Graves Oct 09, 2018

I encountered this same problem today after updated my system Git version to 2.19.1.  I also updated SourceTree to 3.0.6 at the same time.  When pushing a branch, I get the following error:

    fatal: ArgumentException encountered.

       An item with the same key has already been added.

     error: cannot spawn C:\Users\mark.graves\AppData\Local\Sourcetree\app-3.0.6\tools\Askpass.exe: No error

When pushing in this state, I received no prompt to provide credentials to my Git Credential Manager.  Once I changed to use the embedded Git version 2.18.0, I DID get a prompt to provide credentials to the Git Credential Manager, and everything started working.

Jay Goldberg Oct 09, 2018

How do you change to use the embedded Git?

Mark Graves Oct 09, 2018

Tools => Options => "Git" tab => click the "Embedded" button.

Gary Miner Oct 24, 2018

Ran into this issue today with git 2.19.1 and SourceTree 3.0.8. Switching to the embedded git version works. 

Mark Graves Oct 24, 2018

I can also confirm this happened to me on 3.0.8 today after upgrading from 3.0.6.  I switched back to using embedded git version 2.18.0 to fix the issue again.

Gary Miner Oct 24, 2018

I think the issue with 2.19.1 is due to this https://github.com/Microsoft/Git-Credential-Manager-for-Windows/issues/774 which isn't a sourcetree issue per se. I updated my git-credential manager as suggested in this link and I'm working fine with 2.19.1 again.

Simon Thomé Oct 29, 2018

Updating Sourcetree to 3.0.8 and system Git to 2.19.1 I still have the same problem, I can also confirm it is working on embedded Git 2.18.0

1 vote
John Lewin Oct 09, 2018

Also running into this error on fetch in SourceTree. Fetch command line via git works as expected without error

>Were you prompted at all with a Graphical UI for your GH credentials?
No prompts at all, just an endlessly spinning 'Fetching' dialog box

 

Switching to embedded works around the issue for now

1 vote
Daniele Tullo Oct 11, 2018

hi,

had the same issue.

Switching to git version "system", updating embedded and going back to "embedded" seemed to fix it...

 

with each update, i need to pray all divinities that everything is still working...

Reza Seedin Oct 14, 2018

I made the infortunate mistake of hitting update on a Friday before I went on vacation. I didn't realise it was a version 2 to 3 change. I'm back to 2.6.10 and happy days again

1 vote
Ahmed Tarek Oct 18, 2018

Same Problem with me after updating from 2.6.10 to 3.0.6

1 vote
Michael Minns Atlassian Team Oct 22, 2018

A fix for this will be in Sourcetree 3.0.8 which should be rolling out this week. 

0 votes
Bartosz Piec Oct 19, 2018

Two weeks and the bug is still not fixed (but it breaks one of the main features of Source Tree for many users). I also filed a bug: https://jira.atlassian.com/browse/SRCTREEWIN-9318 but didn't get any response. What's wrong Atlassian Team?

Michael Minns Atlassian Team Oct 22, 2018 • edited

We will be rolling out fix this week.

I'm afraid https://jira.atlassian.com has been  hit by  huge number of spam issues in recent weeks so we are a bit behind in our triage.

Simon Thomé Oct 22, 2018

Thanks Michael 

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

371 views 0 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you