Entering in a password in SourceTree?

I just upgraded to the latest version (I tried both 1.3.1 on the App Store and 1.3.2 on the website) and I'm having a problem when trying to push a change to a Google Code Git project. It says that I have an invalid username/password combination. I tried searching everywhere but can't find a place to type in my password for the repository. I even tried creating a new connection to the repostiory in hopes that it will ask me for authentication via a popup dialog or something similar, but I still get the exact same problem. It never asks me for a password for my repository, and I don't see a way to enter in a password.

8 answers

1 accepted

5 votes
Accepted answer

If you don't use SSH keys to authenticate (which are the most secure and convenient way), SourceTree intercepts password prompts from Git and provides a pop-up dialog - at least it does in every instance I've ever seen. I don't have any Google Code projects though, I've mostly tested this with GitHub, BitBucket, Gitorious and so forth. That said, they all work the same way.

If you're not getting a prompt, maybe the URL you're using already has the username & password embedded in it? That's a bad idea but if that's what you've got it might explain it.

Otherwise, when you do 'git push' on the command line, what prompts do you get?

Awesome, thanks! The problem is that by default Google tells you to use a URL in the form of https://USER@code.google.com/p/PROJECT/, which was what I was using. However, after seeing your comment, I removed the "USER@" part and it now prompts me for both a username and password!

Like 1 person likes this

Go to Tools | Options

Click on the Authentication button 

Under Saved Passwords, click Edit and change as needed.

image2016-6-15 10:39:39.png

So, I never get a prompt when trying to push. I get this window that seems to prompt for a password, but I can't type in this window.

Need help with this. What's going on here?

OSX 10.7.5

SourceTree 1.6.3.1

In my case working with Gitlab and SSH keys I had to remove the entries in the keychain... 

When Sourcetree asked for the password, it wasn't properly saved in the keychain (it looked like it was saving just one character), so I manually overwrote it.

After that I granted Always Allow permissions when the keychain prompted to allow Sourcetree to access the password, and after typing the password there, it started working properly again.

So, I tried removing the username from the URL and I did get the prompt. However, the prompt apparently didn't do anything because it's still screaming for a username and password. Any help would be much appreciated.

I'm wondering about this too!

It might be forever later...but better late than never. It looks like this will happen if you the remote url you are using is ssh. The password prompt seems to only be captured for http urls. 

I tried several ways without success, in the end this worked for me, I have installed Source Tree v2.7.1 (156) in MAC OS High Sierra, Menu preferences, Accounts, Basic authentication type, HTTPS protocol

Captura de pantalla 2018-02-13 a la(s) 10.10.22.png

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

828 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you