Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,416
Community Members
 
Community Events
177
Community Groups

Down the rabbit hole trying to get ST to use github PAT

I am getting this error on a waiting push:

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks push -v Robot21C master:master
Completed with errors, see above.

 

So there is no error detail to work with. This all started trying to get ST to use github PAT with basic authentication. With basic, I put in the pat as password and it authenticates successfully...but does not seem to remember the PAT if I go back to the password prompt. Old password seems to still be present. No push. Tried Oauth as well, not sure if that is refreshing correctly but it says authentication ok. Still no push with above error.

All started when the still waiting push was rejected because I was not using a PAT. Trying to get PAT to work led to updating ST and git embedded and ended up with above error.

2 answers

This worked for me:

3. Added the PAT to the repository url like this

https://<personal-access-token>@github.com/<my-repo-url>

- it worked but I didn't like this solution.

4. Restarted PC, installed the newest git from https://git-scm.com - and in Sourcetree - Tools/Options/Git/Git Version - selected "System".

5. Removed the PAT from repository url - still works.

To me it looks like installing the new "git" really helped, so step 3 may be unnecessary, but I can't be sure about that, don't know if it would work without temporarily adding PAT to the url, maybe it also saved something somewhere.

 

I suspect its the git update that fixed it.

So after trying several fixes for PAT authentication I found online  I am back to this:

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks push -v Robot21C master:master
fatal: HttpRequestException encountered.
An error occurred while sending the request.

remote: Support for password authentication was removed on August 13, 2021. Please use a personal access token instead.
remote: Please see https://github.blog/2020-12-15-token-authentication-requirements-for-git-operations/ for more information.
fatal: Authentication failed for 'https://github.com/ORF-4450/Robot21C.git/'

Pushing to https://github.com/ORF-4450/Robot21C.git
Completed with errors, see above.

 

As I work with this, it seems like when I edit the login credential in ST settings and click refresh password and enter the PAT, it authenticates at that moment but does not retain the PAT. When I push immediately after pw refresh, it fails. If I click refresh password again, it appears that the original (non-PAT) password is still there and appears in the entry field. It just seems lie the PAT is not retained and the old pw is used causing the error.

Hi There,

Did you get anywhere with this? I'm getting the same issue!

Thanks,

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events